Bug 60646 - (SOUND I810_AUDIO) "record" on i810 + AC97 will make /dev/dsp busy forever
(SOUND I810_AUDIO) "record" on i810 + AC97 will make /dev/dsp busy forever
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-03 21:49 EST by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-03 21:49:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I rebooted the system. Sound configured normally, and I tested it by playing an
.ogg file. I then ran /usr/bin/record on my system. It recorded sound to a .wav
file. After exiting the program, it was no longer possible to play any audio.
Programs would report that /dev/dsp is busy.

Actual Results:  The recorded .wav files did capture the audio.

/dev/dsp is busy no matter what processes I kill.

Expected Results:  Audio playback should have worked as before.

Additional info:

I am running an IBM X22 laptop and here are the appropriate kernel messages:

Mar  3 17:58:17 localhost kernel: Intel 810 + AC97 Audio, version 0.21, 07:16:09
Feb 26 2002
Mar  3 17:58:17 localhost kernel: PCI: Enabling device 00:1f.5 (0000 -> 0001)
Mar  3 17:58:17 localhost kernel: PCI: Found IRQ 11 for device 00:1f.5
Mar  3 17:58:17 localhost kernel: PCI: Sharing IRQ 11 with 00:1f.3
Mar  3 17:58:17 localhost kernel: PCI: Sharing IRQ 11 with 02:03.1
Mar  3 17:58:17 localhost kernel: PCI: Setting latency timer of device 00:1f.5 to 64
Mar  3 17:58:17 localhost kernel: i810: Intel ICH3 found at IO 0x18c0 and
0x1c00, IRQ 11
Mar  3 17:58:17 localhost kernel: i810_audio: Audio Controller supports 6 channels.
Mar  3 17:58:17 localhost kernel: ac97_codec: AC97 Audio codec, id:
0x4352:0x5936 (Unknown)
Mar  3 17:58:18 localhost kernel: i810_audio: AC'97 codec 0 supports AMAP, total
channels = 2


Here is the message that comes up after recording:
sox: Can't open output file '/dev/dsp': Device or resource busy

I had this behavior both with the 2.4.9-31 kernel and the earlier 2.4.9-21
kernel. I had not tested recording with any earlier release.
Comment 1 Need Real Name 2002-03-18 04:37:13 EST
I have also encountered this same problem on a brand new Dell Dimension P4
1.8GHz desktop system that my cousin purchased and for which I installed RH7.2.
It had an i810 + AC97 audio system as well. 

(On both my own Laptop and my cousin's desktop, WinXP can record without it
interfering with playback in any way. Just wanted to say that to rule out a
fundamental hardware problem here.)

Comment 2 Need Real Name 2002-05-04 16:46:15 EDT
I just tried out the next ALSA release 0.9.0rc1 and it resolves this problem on
the laptop. Recording works on the laptop and does not interfere with playback.

The demo version of the closed-source OSS/Linux drivers also worked on the laptop.
Comment 3 Need Real Name 2002-05-13 19:34:29 EDT
This bug persists in Red Hat 7.3 with the kernel it ships with. record works,
but blocks playback and makes /dev/dsp busy until the modules are unloaded. This
behavior has been observed on both my laptop (IBM X22 with i810 ICH3 and a
cirrus_cs4299 ac97 codec) and my cousin's desktop (Dell P4 1.8 with i810 ICH2
and apparently an AD1885 ac97 codec). Playback works fine by itself.

On the laptop, using alsa 0.9rc1 mostly resolves the problem. Both recording and
playback work and work simultaneously --- gnomemeeting works. However, there are
some clicks and audible problems with certain applications, the game "chromium"
for example.

On the dell desktop, alsa 0.9rc1 does not resolve the problem in the sense that
the alsa drivers do not give any audible playback at all. OSS/Linux commercial
driver demo also does not work properly on the dell desktop, though in a
different way. It plays back way too fast.
Comment 4 Doug Ledford 2002-11-08 13:12:45 EST
The fix for this bug was recently tracked down by a user on the internet.  It
has been forwarded to Alan Cox for inclusion in the official kernel sources and
also to our internal kernel person for inclusion in our next kernel errata.
Comment 5 Need Real Name 2002-11-16 23:49:49 EST
I just tried the new errata kernel:

 Linux version 2.4.18-18.7.x (bhcompile@bugs.devel.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.3 2.96-112)) #1 Wed Nov 13 20:29:30 EST 2002

and the bug is still present in the kernel OSS drivers. Upon trying to record
using my X22 laptop, /dev/dsp becomes busy forever. So I am reopening this bug.
Comment 6 Alan Cox 2003-06-09 08:38:01 EDT
Should be fixed in 2.4.21rc Arjan. If you try and record while something (esd I
guess) has the channel open for read you can end up with the audio busy and stuck
Comment 7 Bugzilla owner 2004-09-30 11:39:24 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.