Bug 606628 - anaconda crash when renaming new logical volume
Summary: anaconda crash when renaming new logical volume
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:6d3b4f3461484ba47...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 06:21 UTC by Sean Flanigan
Modified: 2011-12-21 18:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-21 18:00:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (468.54 KB, text/plain)
2010-06-22 06:21 UTC, Sean Flanigan
no flags Details
Attached traceback automatically from anaconda. (369.87 KB, text/plain)
2010-09-30 17:26 UTC, Joseph Boyer Jr.
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 579025 None None None Never

Description Sean Flanigan 2010-06-22 06:21:32 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 913, in updateLogVolStore
    format = self.luks[lv['name']]
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 797, in editLogicalVolume
    self.updateLogVolStore()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1781, in editLVMLogicalVolume
    vgeditor.editLogicalVolume(lv, isNew = isNew)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1644, in editCB
    self.editLVMLogicalVolume(lv = device)
KeyError: 'lv_swap'

Comment 1 Sean Flanigan 2010-06-22 06:21:37 UTC
Created attachment 425833 [details]
Attached traceback automatically from anaconda.

Comment 2 Sean Flanigan 2010-06-23 00:09:56 UTC
Short version: this traceback happened when I went back in to edit the name of a new logical volume, during manual partitioning ("custom layout).

The long version was lost when Bugzilla rejected my See Also bug.

This looks like the same traceback as bug 579025.  Don't ask me why it's so short.

Comment 3 Joseph Boyer Jr. 2010-09-30 17:26:50 UTC
Created attachment 450824 [details]
Attached traceback automatically from anaconda.

Comment 4 Vinny 2011-04-20 15:41:01 UTC
This has also been seen on RHEL 6.
Do we need a separate ticket ?

"Errors reported by RedHat install log, editing an LV spec:
18:40:59,862 CRITICAL: anaconda 13.21.82 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 928, in updateLogVolStore
    format = self.luks[lv['name']]
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 812, in editLogicalVolume
    self.updateLogVolStore()
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 861, in addLogicalVolumeCB
    self.editLogicalVolume(self.lvs[name], isNew = 1)
KeyError: 'LVroot'

18:41:18,781 CRITICAL: anaconda 13.21.82 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 928, in updateLogVolStore
    format = self.luks[lv['name']]
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 812, in editLogicalVolume
    self.updateLogVolStore()
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 861, in addLogicalVolumeCB
    self.editLogicalVolume(self.lvs[name], isNew = 1)
KeyError: 'LVroot'"

Comment 5 Vinny 2011-05-10 18:50:59 UTC
The user who reported this problem, mentioned that the problem might be on the following portion of the code:
"Lines 795-797:

  if self.luks.has_key(origname) and origname != templv.lvname:
       self.luks[templv.lvname] = self.luks[origname]
       del self.luks[templv.lvname]"

Should delete self.luks[origname], not self.luks[templv.lvname]; let me know if you need any additional verification.

Comment 6 Chris Lumens 2011-12-21 18:00:19 UTC
All this old UI code is on the way out for F17, so there's no point in us looking at this.  Thanks for taking a look at it yourself, though.


Note You need to log in before you can comment on or make changes to this bug.