Bug 606643 - rhel4-i386 with smp kernel stop at "PCI: Probing PCI hardware" during booting
rhel4-i386 with smp kernel stop at "PCI: Probing PCI hardware" during booting
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
:
: 605164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 02:43 EDT by Suqin Huang
Modified: 2010-11-10 13:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-24 05:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-06-22 02:43:21 EDT
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.78.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest
qemu-kvm -name 'vm1' -drive file=/images/RHEL-4.8-32.qcow2,if=ide,cache=none,boot=on,aio=native \
-net nic,vlan=0,model=e1000,macaddr=02:0E:D3:48:44:8f \
-net tap,vlan=0,ifname=e1000_0_6001,script=/qemu-ifup-switch,downscript=no,vhost=on -m 2048 -smp  -redir tcp:5000::22 -vnc :0 -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection -chardev stdio,id=serial0 -device isa-serial,chardev=serial0

2. update guest kernel to 2.6.9-89.28.ELsmp
3. reboot
  
Actual results:
guest stop during booting:

NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xffe77, last bus=0
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040816
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)

Expected results:


Additional info:
guest: rhel4-i386 with kernel 2.6.9-89.28.ELsmp
can boot guest with up kernel.
Comment 2 RHEL Product and Program Management 2010-06-22 03:03:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Juan Quintela 2010-06-23 06:41:53 EDT
*** Bug 605164 has been marked as a duplicate of this bug. ***
Comment 4 Michael S. Tsirkin 2010-06-23 08:59:01 EDT
I was unable to reproduce this:

ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking if image is initramfs... it is
Freeing initrd memory: 1184k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xffe77, last bus=0
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040816
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Link [LNKA] (IRQs 5 *10 11)
ACPI: PCI Interrupt Link [LNKB] (IRQs 5 *10 11)
ACPI: PCI Interrupt Link [LNKC] (IRQs 5 10 *11)
ACPI: PCI Interrupt Link [LNKD] (IRQs 5 10 *11)

and boot proceeds.
So my guess is the issue is ACPI, not PCI.
what is the address of a machine where this happens?
Comment 5 Michael S. Tsirkin 2010-06-23 09:08:52 EDT
note I passed -smp 2, not -smp.
Comment 6 Michael S. Tsirkin 2010-06-23 09:36:06 EDT
also pls provide host info:
kernel version, cat /proc/cpuinfo
Comment 7 Michael S. Tsirkin 2010-06-23 09:38:24 EDT
my command line for reference:

/usr/libexec/qemu-kvm -enable-kvm -m 2048 -drive file=/home/mst/rhel48-32.qcow2,if=ide,cache=none,boot=on,aio=native -netdev tap,ifname=msttap0,script=/home/mst/ifup,downscript=no,vhost=on,id=bar -net nic,netdev=bar,model=e1000  -redir tcp:8022::22 -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2,vendor=AuthenticAMD -no-kvm-pit-reinjection -chardev stdio,id=serial0 -device isa-serial,chardev=serial0 -snapshot -smp 2
Comment 8 Suqin Huang 2010-06-24 02:41:47 EDT
I can reproduce with your command

1. host cpu:
processor	: 3
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: AMD Phenom(tm) 9600B Quad-Core Processor
stepping	: 3
cpu MHz		: 1150.000

flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs npt lbrv svm_lock

2. kernel:
2.6.32-36.el6.x86_64

3. guest boot info:

ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking TSC synchronization across 2 CPUs: 
CPU#0 had -1405593 usecs TSC skew, fixed it up.
CPU#1 had 0 usecs TSC skew, fixed it up.
Brought up 2 CPUs
zapping low mappings.
checking if image is initramfs... it is
Freeing initrd memory: 1560k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xffe77, last bus=0
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
mtrr: your CPUs had inconsistent variable MTRR settings
mtrr: your CPUs had inconsistent MTRRdefType settings
mtrr: probably your BIOS does not setup all CPUs.
mtrr: corrected configuration.
ACPI: Subsystem revision 20040816
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
Comment 9 Gleb Natapov 2010-06-24 03:12:20 EDT
Does it hang with -smp 1 too? Can you try with this kernel rpm (on the host):
https://brewweb.devel.redhat.com/getfile?taskID=2515192&name=kernel-2.6.32-33.el6glebirr.x86_64.rpm
Comment 10 Suqin Huang 2010-06-24 03:45:53 EDT
can reproduce with -smp 1
error when I open the link, pls provide it again.
Comment 11 Gleb Natapov 2010-06-24 03:57:44 EDT
(In reply to comment #10)
> error when I open the link, pls provide it again.    
It was removed from brew already. Will resubmit new job.
Can you find what is the first  2.6.9-89.X.ELsmp that fails?
Comment 12 Suqin Huang 2010-06-24 04:57:25 EDT
can not reproduce with a new installed image.

Note You need to log in before you can comment on or make changes to this bug.