Bug 606665 - tests failing because of missing lsb_release
Summary: tests failing because of missing lsb_release
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 08:00 UTC by Petr Šplíchal
Modified: 2019-05-22 13:34 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-07-13 18:39:37 UTC


Attachments (Terms of Use)

Description Petr Šplíchal 2010-06-22 08:00:57 UTC
Description of problem:

Seems the redhat-lsb package is now missing in the default
install. Tests using this to differentiate their behaviour
depending on the release are now failing. This has changed
recently. Exactly the same test passed a few weeks ago.

Version-Release number of selected component (if applicable):
0.5.44 

Error message:
/usr/share/beakerlib//plugins/rh-internal.sh:
        line 242: lsb_release: command not found

Passing job:
https://beaker.engineering.redhat.com/jobs/1906
https://beaker.engineering.redhat.com/logs/2010/06/1906/3606/31656///TESTOUT.log

Failing job:
https://beaker.engineering.redhat.com/jobs/4403
https://beaker.engineering.redhat.com/logs/2010/03/4403/7705/84751///TESTOUT.log

Comment 1 Bill Peck 2010-06-22 15:21:11 UTC
I added redhat-lsb to the install task.

Comment 2 Marian Csontos 2010-06-23 07:00:02 UTC
BTW, should not that be beakerlib-redhat's dependency?

Comment 3 Petr Muller 2010-06-23 13:26:30 UTC
We will add that dep


Note You need to log in before you can comment on or make changes to this bug.