Bug 606672 - perf: Fatal: reading input file (size expected=3 received=0)
Summary: perf: Fatal: reading input file (size expected=3 received=0)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Olsa
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 08:13 UTC by Qian Cai
Modified: 2016-02-10 13:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 08:16:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Qian Cai 2010-06-22 08:13:04 UTC
Description of problem:
# perf record -R -f ls
# perf report
  Fatal: reading input file (size expected=3 received=0)
# perf report -D
  Fatal: reading input file (size expected=3 received=0)
# perf trace
  Fatal: reading input file (size expected=3 received=0)

Looks like got fixed upstream,
http://lkml.org/lkml/2010/5/1/2

Under a guest, got a different behaviour,

# perf report
  Fatal: no trace data in the file
# perf report -D
  Fatal: no trace data in the file
# perf trace
  Fatal: no trace data in the file

Version-Release number of selected component (if applicable):
perf-2.6.32-37.el6.noarch

How reproducible:
always

Comment 3 Jiri Olsa 2010-12-28 12:00:54 UTC
FYI, this works for me in upstream (v2.6.37-rc6)

jirka

Comment 4 RHEL Product and Program Management 2011-01-07 04:44:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Suzanne Yeghiayan 2011-01-07 16:15:29 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 6 RHEL Product and Program Management 2011-02-01 06:15:38 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 Jiri Olsa 2011-04-05 08:16:27 UTC
Itested this on the latest RHEL6 and this got 
fixed by 2.6.38 perf sync, via BZ 664900


Note You need to log in before you can comment on or make changes to this bug.