Bug 60669 - Bad word break in man pages
Bad word break in man pages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 11:41 EST by David Balažic
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 04:21:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2002-03-04 11:41:58 EST
In man pages a wrong character ( upside down exclamation mark (!, just
upside down)) is used to perform word breaks. Example :

blah blah bla blah bla!
lah bla

instead of :
blah blah bla blah bla-
lah bla

Running man on VT1, LANG=en_US , LC_ALL is unset
Comment 1 Bernhard Rosenkraenzer 2002-03-04 12:27:14 EST
Works for me... Which console font/charset are you using?
Comment 2 David Balažic 2002-03-05 03:59:36 EST
This is my /etc/sysconfig/i18n file , hope it answers your question. I just 
boot up and do not make any changes, just run "man ls" , for exmaple :

LANG="en_US"
SUPPORTED="bs_BA:bs:hr_HR:hr:en_CA:en:en_GB:en:en_IE@euro:en_IE:en:en_US:en:fi_F
I@euro:fi_FI:fi:fr_CA:fr:fr_FR@euro:fr_FR:fr:de_AT@euro:de_AT:de:de_DE@euro:de_D
E:de:hu_HU:hu:it_IT@euro:it_IT:it:mk_MK:mk:sl_SI:sl:es_ES@euro:es_ES:es"
SYSFONT="lat0-sun16"
SYSFONTACM="iso01
Comment 3 Bernhard Rosenkraenzer 2002-03-07 10:07:08 EST
Odd, can't reproduce it with the exact same settings.
[root@zell root]# rpm -q man console-tools
man-1.5j-5
console-tools-19990829-36

Please reopen if you can reproduce this anywhere else/find a way to make it
reproducable.
Comment 4 David Balažic 2002-03-13 04:21:08 EST
I am working with Hampton beta-1.

If I rename/remove the /etc/sysconfig/i18n file and relogin, then the problem 
is gone. But if I do this, the it is back :

echo -n -e '\033(K'
LANG=en_US man ls

I have man-1.5j-2 and no console-tools installed.
Comment 5 Bernhard Rosenkraenzer 2002-03-19 09:49:58 EST
The problem is that you're still using the kbd package from 8.x along with a 7.x system. 
That's not going to work. Install console-tools from the current tree.

Note You need to log in before you can comment on or make changes to this bug.