Bug 606702 - No mouse/keyboard after update to F13
Summary: No mouse/keyboard after update to F13
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 09:21 UTC by Radek Novacek
Modified: 2016-12-01 00:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 06:09:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg (40.66 KB, text/plain)
2010-06-22 09:21 UTC, Radek Novacek
no flags Details
/var/log/messages (75.48 KB, text/plain)
2010-06-22 09:29 UTC, Radek Novacek
no flags Details

Description Radek Novacek 2010-06-22 09:21:57 UTC
Created attachment 425875 [details]
Output of dmesg

After I updated to Fedora 13 using "yum update", xorg doesn't detect my keyboard and mouse. I see login screen but keyboard and mouse is not responsive. Keyboard works fine in terminal.

After some digging in I have figured out that there aren't any input devices in the /dev/input/*. There are only two directories: by-id and by-path with following content:

# ls -lF /dev/input/*                                                                                                                 
/dev/input/by-id:
total 0
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 usb-0461_USB_Optical_Mouse-event-mouse -> ../../event3
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 usb-0461_USB_Optical_Mouse-mouse -> ../../mouse1
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 usb-Dell_Dell_USB_Keyboard-event-kbd -> ../../event4

/dev/input/by-path:
total 0
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 pci-0000:00:1d.1-usb-0:2:1.0-event-mouse -> ../../event3
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 pci-0000:00:1d.1-usb-0:2:1.0-mouse -> ../../mouse1
lrwxrwxrwx. 1 root root 12 Jun 22 10:10 pci-0000:00:1d.2-usb-0:1:1.0-event-kbd -> ../../event4

Versions:
udev-151-10.fc13.i686
xorg-x11-server-Xorg-1.8.0-12.fc13.i686

After I set "AutoAddDevices" to False in xorg.conf and write mouse configuration there, keyboard and mouse works normally.

Comment 1 Radek Novacek 2010-06-22 09:29:48 UTC
Created attachment 425878 [details]
/var/log/messages

Comment 2 Harald Hoyer 2010-06-22 09:56:39 UTC
Something is borken! your "event*" and "mouse*" devs are not in /dev/input, but in /dev!

What is the output of:

$ cat /sys/class/input/*/uevent|grep DEVNAME
$ DEVPATH=$(readlink -f /sys/class/input/mouse1)
$ udevadm test ${DEVPATH##/sys}

Comment 3 Radek Novacek 2010-06-23 06:09:30 UTC
That's weird, today is everything OK. I can't to get it to work yesterday, but today everything looks fine, devices are back in /dev/input.

Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.