Bug 60671 - broken preuninstall script
broken preuninstall script
Status: CLOSED DUPLICATE of bug 55091
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 12:04 EST by James Manning
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 12:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-03-04 12:04:29 EST
Doing fresh 7.2 install and up2date -u run today:


17:iptables               ########################################### [16%]
/var/tmp/rpm-tmp.92298: [: /var/tmp/rpm-tmp.92298: integer expression expected

[jmm@localhost jmm]$ rpm -q --scripts iptables
postinstall scriptlet (through /bin/sh):
chkconfig --add iptables
preuninstall scriptlet (through /bin/sh):
if [ "$1" = 0 ]; then
        chkconfig --del iptables
fi

I'd imagine making it "0" instead of 0 should do it, but I'm not sure about 
the param passing that's happening

This could be a dup, but I'm prob. searching on the wrong strings.
Comment 1 Ben Levenson 2002-03-04 15:48:02 EST

*** This bug has been marked as a duplicate of 55091 ***

Note You need to log in before you can comment on or make changes to this bug.