Bug 606755 - v7 unknown command run
v7 unknown command run
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.2
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
: 608538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 08:29 EDT by Petr Beňas
Modified: 2015-01-04 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The v7 program no longer fails with the "unknown command: run" error message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 08:14:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Beňas 2010-06-22 08:29:11 EDT
Description of problem:
v7 run does not work

Version-Release number of selected component (if applicable):
1.2-7

How reproducible:
always

Steps to Reproduce:
[root@dhcp-29-193 v7]# v7 version
V7 version 1.2, release 7
[root@dhcp-29-193 v7]# v7 plan
loaded results /var/v7/results.xml
Tested OS: Red Hat Enterprise Linux Server 6 (Santiago)
Kernel RPM: kernel-2.6.32-36.el6
v7 version 1.2, release 7
saved test plan to /var/v7/results.xml
[root@dhcp-29-193 v7]# v7 print

Test Plan:
----------------------------------------------------------------
usb                                                        
suspend               computer_power_supply_battery_BAT0   
battery               computer_power_supply_battery_BAT0   
network    wlan1      net_00_1c_bf_6e_a3_c4                
network    eth1       net_00_1e_37_1e_37_82                
fv_network                                                 
fv_storage                                                 
fv_core                                                    
fv_memory                                                  
info                                                       
reboot                                                     
lid                   computer_logicaldev_input_3          
video                 pci_8086_2a02                        
cdrom      sr0        storage_model_DVDRAM_GSA_U10N        
dvd        sr0        storage_model_DVDRAM_GSA_U10N        
storage    sda        storage_serial_HITACHI_HTS723216L9SA60_090714FC1220NCHB23WH 
memory                                                     
audio                 pci_8086_284b_sound_card_0_alsa_playback_1 
cpuscaling 0          acpi_CPU0                            
cpuscaling 1          acpi_CPU1                            
profiler                                                   
core                                                       
pccard                pci_1180_476                         
[root@dhcp-29-193 v7]# v7 run --test info
loaded results /var/v7/results.xml
Tested OS: Red Hat Enterprise Linux Server 6 (Santiago)
Kernel RPM: kernel-2.6.32-36.el6
v7 version 1.2, release 7
saved test plan to /var/v7/results.xml

Running info:
---------------------------------
unknown command: run
  
Actual results:
unknown command: run

Expected results:
test is executed

Additional info:
Comment 1 Rob Landry 2010-06-28 10:39:18 EDT
*** Bug 608538 has been marked as a duplicate of this bug. ***
Comment 2 Greg Nichols 2010-07-06 10:49:56 EDT
A work-around appears to be the use of the --debug option.

Try:

v7 run --test info --debug low
Comment 3 Greg Nichols 2010-07-06 11:23:21 EDT
Fixed via https://fedorahosted.org/v7/changeset/550 (the last change at the end adds some exception handling.)
Comment 7 errata-xmlrpc 2010-09-20 08:14:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html
Comment 8 Jaromir Hradilek 2010-09-21 08:58:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The v7 program no longer fails with the "unknown command: run" error message.

Note You need to log in before you can comment on or make changes to this bug.