Bug 60690 - illegal argument error in hwbrowser
illegal argument error in hwbrowser
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 16:06 EST by Wayne Miller
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 16:06:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wayne Miller 2002-03-04 16:06:47 EST
Description of Problem:

When I run the hwbrower it traps and quits.
Version-Release number of selected component (if applicable):
Came with RH V 7.2

How Reproducible:
When I run the hwbrower it traps and quits.

Steps to Reproduce:
1. run the hwbrowser from the command line
2. 
3. 

Actual Results:
Traceback (innermost last):
  File "/usr/share/hwbrowser/DeviceList.py", line 158, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 151, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 398, in initialize
    disk = parted.PedDevice.get ('/dev/' + device.kudzu_device.device)
TypeError: illegal argument type for built-in operation


Expected Results:
A window tree-view of the hardware

Additional Information:
Comment 1 Jonathan Blandford 2002-03-18 14:35:29 EST
I believe this is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.