Bug 60694 - unexpected behavior when querying rpmdb-redhat
unexpected behavior when querying rpmdb-redhat
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 17:11 EST by Ben Levenson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 17:45:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-03-04 17:11:09 EST
Description of Problem:
on i386:
 [root@i386-72 i386]# locate libcapplet.so.0
 /usr/lib/libcapplet.so.0.0.0
 /usr/lib/libcapplet.so.0

 [root@i386-72 i386]# rpm -q --redhatprovides libcapplet.so.0
 control-center-1.4.0.1-18

on ia64:
 [root@ia64-72 sysconfig]# locate libcapplet.so.0
 /usr/lib/libcapplet.so.0.0.0
 /usr/lib/libcapplet.so.0

 [root@ia64-72 sysconfig]# rpm -q --redhatprovides libcapplet.so.0
 no package provides libcapplet.so.0

'--redhatprovides' will work if the full path to libcapplet is provided...

Version-Release number of selected component (if applicable):
rpmdb-redhat-7.2-0.20011214
rpm-4.0.3-1.03

How Reproducible:
100%
Comment 1 Tim Powers 2002-03-04 17:18:07 EST
Jeff, have you seen this behviour before? 

Tim
Comment 2 Tim Powers 2002-03-04 17:25:24 EST
I able to verify that the behaviour is definitely differnt. I logged into
natasha and ran the same commands Ben entered, and have the same results.

Tim
Comment 3 Ben Levenson 2002-03-04 17:32:49 EST
FWIW, I receive similar results if I query via up2date:
  i386:
  [root@iccthedral root]# up2date --whatprovides libcapplet.so.0
  control-center-1.4.0.1-18

  ia64:
  [root@ia64-72 root]# up2date --whatprovides libcapplet.so.0
  Unable to solve deps for  ['libcapplet.so.0']
Comment 4 Tim Powers 2002-03-04 17:45:39 EST
Looks like a change in behaviour for rpm itself. The rpmdb is created from the
same specfile, and in the same way for all arches. I'm changing the package this
was filed against to rpm and reassigning to Jeff.

Tim
Comment 5 Tim Powers 2002-03-04 17:53:35 EST
Bill just straitened everything out "one's a file, the other is a dependancy".

On x86 you were querying a dependancy, the same dependancy doesn't exist on
ia64, this works on ia64:

rpm -q --redhatprovides "libcapplet.so.0()(64bit)"

I'm closing this since it's not a bug.

Jeff, beat me senseless later.

Tim

Note You need to log in before you can comment on or make changes to this bug.