Bug 606963 - Storage test fail on RH6 certification
Storage test fail on RH6 certification
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
CAI Qian
:
: 612323 614555 621104 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 15:47 EDT by chau nguyen
Modified: 2010-10-23 11:41 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Running the storage test on Red Hat Enterprise Linux 6 now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 08:13:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This log LVM default partition (12.21 KB, application/octet-stream)
2010-06-22 15:47 EDT, chau nguyen
no flags Details
This log is create swap, boot, and root partitions (37.58 KB, application/octet-stream)
2010-06-22 15:53 EDT, chau nguyen
no flags Details
sosreport (827.39 KB, application/x-xz)
2010-07-16 16:36 EDT, IBM Bug Proxy
no flags Details
RH6 snapshot 11 and v7-1.2-17 storage output (60.64 KB, application/octet-stream)
2010-08-20 16:17 EDT, chau nguyen
no flags Details
rhel6-snapshot-7 with v7 version r18 & r20 (54.84 KB, text/plain)
2010-08-25 14:19 EDT, Caspar Zhang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0702 normal SHIPPED_LIVE v7 bug fix and enhancement update 2010-10-21 03:59:09 EDT

  None (edit)
Description chau nguyen 2010-06-22 15:47:21 EDT
Created attachment 426068 [details]
This log LVM default partition

Description of problem:
Storage test fail on RH6 certification

Version-Release number of selected component (if applicable):


How reproducible:
Install RH6 snapshot 6 
Install Test kit v7 version 7-1.2-3
Ran Storage test and failed.


Steps to Reproduce:
1. Install RH6 snapshot 6 
2. Install Test kit v7 version 7-1.2-3
3. Ran Storage test and failed.

Actual results:
Fail

Expected results:
Pass

Additional info:
Configuration
System:  ML370 G7
System BIOS: P63 05/14/2010
OS:  Rathat 6 snapshot 6
Test version: v7-1.2.3

I had tried two storage configurations test.
-  One, leave all LVM partition as default and ran the test --- fail
-  Second delete all LVM partition and create boot, swap, and root partitions 
   and ran the test ----fail
Comment 1 chau nguyen 2010-06-22 15:53:44 EDT
Created attachment 426072 [details]
This log is create swap, boot, and root partitions
Comment 2 Rob Landry 2010-07-16 16:31:27 EDT
*** Bug 614555 has been marked as a duplicate of this bug. ***
Comment 4 IBM Bug Proxy 2010-07-16 16:36:15 EDT
Created attachment 432490 [details]
sosreport
Comment 5 chau nguyen 2010-07-21 16:25:06 EDT
This test also fail inside the KVM.
Comment 6 Gary Smith 2010-08-02 11:21:21 EDT
Additional info from BZ#612323:


storage.py (devSize()) uses the following command to figure out the device
major/minor number:

file -L /dev/sdc |sed -r 's|.*special .([0-9]+)/([0-9]+).|\\1 \\2|'

...but "file -L" does not print the major/minor number under RHEL6
(beta1snap6):

$ file -L /dev/sdc
/dev/sdc: block special

...whereas earlier distributions would print:

$ file /dev/sdc
/dev/sdc: block special (8/32)

storage.py needs to find a different way to find out storage device sizes.
Comment 7 Gary Smith 2010-08-02 11:22:02 EDT
*** Bug 612323 has been marked as a duplicate of this bug. ***
Comment 10 Martin Wilck 2010-08-03 13:34:04 EDT
I checked v7 1.2-14 and the bug from comment #6 seems to be still in there.
Comment 11 Greg Nichols 2010-08-04 07:10:22 EDT
*** Bug 621104 has been marked as a duplicate of this bug. ***
Comment 12 Martin Wilck 2010-08-17 12:05:44 EDT
Seems to be solved in 1.2-16.
Comment 13 IBM Bug Proxy 2010-08-19 10:43:07 EDT
------- Comment From luciojhc@br.ibm.com 2010-08-19 10:38 EDT-------
Closing bug per the last comments.

------- Comment From luciojhc@br.ibm.com 2010-08-19 10:40 EDT-------
Comment  #24 From Hien Nguyen  2010-08-17 16:01:53 EST  [reply] -------
Internal Only

The storage test passed with v7-1.2-16 (alpha 4) on RHEL6 snap10.

-------
Comment 15 chau nguyen 2010-08-20 16:16:27 EDT
The test failed on RH6 x64 snapshot 11 and v7-1.2-17 test kit.  The swap partition is 14GB before the test, but after test swap partition is 0.  Swap partitions is still 0 after reboot the  system.

*** Raw I/O testing passed.

swap device has no label.
restoring swap device /dev/dm-1 ...
Error: could not restore swap
"mkswap   /dev/dm-1" has output on stderr
Error: restore swap error !
...finished running ./storage.py, exit code=1
</output>
Comment 16 chau nguyen 2010-08-20 16:17:36 EDT
Created attachment 440043 [details]
RH6 snapshot 11 and v7-1.2-17 storage output
Comment 17 Greg Nichols 2010-08-20 17:11:26 EDT
(In reply to comment #15)
> The test failed on RH6 x64 snapshot 11 and v7-1.2-17 test kit.  The swap
> partition is 14GB before the test, but after test swap partition is 0.  Swap
> partitions is still 0 after reboot the  system.
> 
> *** Raw I/O testing passed.
> 
> swap device has no label.
> restoring swap device /dev/dm-1 ...
> Error: could not restore swap
> "mkswap   /dev/dm-1" has output on stderr
> Error: restore swap error !
> ...finished running ./storage.py, exit code=1
> </output>

This looks like bug 621070 - resolved in R18.   Could you try R18 please?
Comment 18 Caspar Zhang 2010-08-25 14:16:54 EDT
Tested r18, r20 in a Snapshot7 machine, both errors in #c3 and #c15 have disappeared. If qcui confirms that she doesn't trigger the bug in new v7 versions too, the bug can be moved to `VERIFIED'.
Comment 19 Caspar Zhang 2010-08-25 14:19:13 EDT
Created attachment 441015 [details]
rhel6-snapshot-7 with v7 version r18 & r20
Comment 20 qcui 2010-08-26 03:00:43 EDT
Verified it on ppc64,s390x,x86_64 with v7-1.2-21.el6.
Comment 23 errata-xmlrpc 2010-09-20 08:13:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html
Comment 24 Jaromir Hradilek 2010-09-21 08:58:37 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Running the storage test on Red Hat Enterprise Linux 6 now works as expected.

Note You need to log in before you can comment on or make changes to this bug.