Bug 60701 - not statically linked
not statically linked
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: busybox (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
: 60702 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 19:52 EST by Matt Selsky
Modified: 2007-04-18 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 06:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Selsky 2002-03-04 19:52:26 EST
/sbin/busybox should be statically linked, not dynamically linked.

From the source rpm, it looks like the file busybox-static.patch contains the
wrong thing.  I looked at the srpm for busybox-0.51.xxx and it contains what
looks like the proper patch file for static linking.

This breaks anything boot/rescue disk which is relying on busybox not needing
other libraries.
Comment 1 Bill Nottingham 2002-03-28 17:46:37 EST
*** Bug 60702 has been marked as a duplicate of this bug. ***
Comment 2 Matt Wilson 2002-04-02 15:07:01 EST
Erik, Jeremy - opinions?  I've never actually touched busybox.  (May be I'm not
the best package owner for it...)
Comment 3 Jeremy Katz 2002-04-02 15:30:58 EST
Oops, I left that part out when updating the patch for the new version. 
Building updated version now (0.60-4)
Comment 5 Ivana Varekova 2006-01-09 06:52:26 EST
The RHEL3 problem has its separate bug report (131663) which in state closed now. 
The devel version is fixed. I'm closing this bug. 
If there is any problem please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.