Bug 607018 - does not show up in menus/launchers - NoDisplay=true
does not show up in menus/launchers - NoDisplay=true
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 567088 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 19:54 EDT by Richard Z.
Modified: 2010-07-14 19:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: xterm-261-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 19:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Z. 2010-06-22 19:54:54 EDT
Hi,

on my F12 system xterm does not show up in any KDE menus, launchers etc.. I have been told it is because of the said setting in the desktop file. Apparently it is shown in gnome menus - which is considered a bug.

see https://bugzilla.redhat.com/show_bug.cgi?id=567088

Could you please change this setting? I have installed xterm obviously because I want to use it. Current setting makes it impossible to add it to favorites or create desktop shortcuts in KDE.
Comment 1 Thomas E. Dickey 2010-06-23 04:55:41 EDT
See my comments in #567088 (there are desktop files in xterm
for the past 3 years which can be used).
Comment 2 Miroslav Lichvar 2010-06-23 05:46:55 EDT
xterm still should be available in the menu editor.

IIRC, NoDisplay=true was added to the desktop file, because gnome guys were complaining that there were two terminal emulators in gnome menu by default.

If that's no longer the case I've no problem with removing it.
Comment 3 Richard Z. 2010-06-23 15:55:09 EDT
Thanks for looking at it. As far as I know xterm is not installed by default anywhere so it should not be that much of a problem for gnome. I would not even complain if it was hidden in some legacy-submenu - in fact I would probably end up using that menu quite often. But as it is now it is some effort to get an icon on the desktop in KDE or add it to the favorites in the KDE launcher.

If gnome has a specific problem with xterm (or as we say the problem is in front of the screen) they might do something like Categories=notGnome; ?
Comment 4 Richard Z. 2010-06-24 16:15:45 EDT
Thought about it more, perhaps the desktop file should be in a separate package so that it would not be there at ell if xterm was dragged in just to satisfy some dependencies?

This would leave even Gnome users the choice if they want to see it in their menus.
Comment 5 Miroslav Lichvar 2010-06-25 03:16:19 EDT
*** Bug 567088 has been marked as a duplicate of this bug. ***
Comment 6 Thomas E. Dickey 2010-06-25 04:04:31 EDT
One or the other (comments 3 and 4).  Omitting it is a bug.
Comment 7 Miroslav Lichvar 2010-07-01 03:15:45 EDT
Can anyone confirm that xterm is not in default installation anymore?
Comment 8 Thomas E. Dickey 2010-07-01 17:40:59 EDT
Fedora doesn't seem to have a page listing the pages it installs by
default (something that would be useful to other people).

googling tends to indicate that Fedora 10 made it not in the default
install, due to the comments of people who found they had to install
it themselves.  For instance

http://www.howtoforge.com/how-to-install-ailurus-10.01.5-on-fedora

(I did't recall whether it was installed by default in Fedora 12,
since I did that along with other installs - none of the Linux
distributions provide a usable development environment by default,
though SuSE is pretty good).
Comment 9 Miroslav Lichvar 2010-07-02 08:28:56 EDT
Thanks, Thomas.

I went through comps and some repoqueries and it seems that it's installed by default in the KDE spin.

It's pulled in by kde-settings-kdm, because it's a requirement for failsafe session (bug #491251).

I'll go with assumption that KDE users won't be confused by having two terminal emulators in the menu and just remove the NoDisplay line from the desktop file (switch to the upstream version), first in devel and F-13, and maybe later in F-12.

Let me know if this is a bad idea.
Comment 10 Fedora Update System 2010-07-02 08:35:50 EDT
xterm-261-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xterm-261-2.fc13
Comment 11 Thomas E. Dickey 2010-07-02 17:01:37 EDT
Sounds fine (though xterm installs two desktop files, one for
"xterm" and one for "uxterm", which was not mentioned in this
report).
Comment 12 Fedora Update System 2010-07-06 13:25:40 EDT
xterm-261-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xterm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xterm-261-2.fc13
Comment 13 Fedora Update System 2010-07-14 19:00:07 EDT
xterm-261-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.