Bug 60705 - Connection fails (configuration utilities don't erase /etc/ppp/peers/pppx)
Summary: Connection fails (configuration utilities don't erase /etc/ppp/peers/pppx)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-05 03:49 UTC by fred-m
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 00:41:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fred-m 2002-03-05 03:49:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
One more bug on redhat-config-network. I re-defined my modem-based internet
connection with internet-druid, and later changed it with neat several times. In
one of these times a /etc/ppp/peers/ppp0 file remained from a previous
configuration. Deleting the definition of the connection (on the "devices" tab
of neat), or re-defining it (with internet-druid) does not delete this file. If
the setup in this file is different from the one in the current connection
(e.g., if the connection nickname doesn't match the one on wvdial), connection
fails.

For short, internet-druid is not deleting /etc/ppp/peers/ppp<x> when setting
connection for the ppp<x> device (I wonder if neat should delete it also).

(BTW, on a separate note, shouldn't internet-druid by default set the
connections it creates as default route?).


Version-Release number of selected component (if applicable):
I'm using all updates up to Feb 22.

How reproducible:
Always

Steps to Reproduce:
1. Erase all modem-based internet connections (so that the next connection
should be set on ppp0).
2. Execute "touch /etc/ppp/peers/ppp0"
3. Define a modem-based internet connection with internet-druid and/or neat.
Execute "chmod 644 /etc/sysconfig/network-scripts/ifcfg-ppp0" (see bug 56579).
Try it, and verify that it fails (ppp doesn't call wvdial since
/etc/ppp/peers/ppp0 is blank). 
4. Execute "rm /etc/ppp/peers/ppp0"
5. Try again to connect, and verify that it works.


Actual Results:  Does not even activate modem (ppp fails to call wvdial)


Expected Results:  Connection works after running internet-druid (or neat
afterwards)


Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-03-28 20:48:58 UTC
Is this still a problem with 0.9.20-1, found at http://people.redhat.com/teg/neat/?

Comment 2 fred-m 2002-04-01 04:00:23 UTC
First, it seems that the original ppp configuration (before updating
to 0.9.20-1) was not fully preserved after the update. I need to
re-configure it to make it work, but after re-configuring
I cannot make the connection work, even without "touch
/etc/ppp/peers/ppp0" to make the bug happen.

Here is what I am trying to re-configure the interface. I delete the
ppp connection configuration in neat, then do the following to really
clean the setup:
    rm /etc/sysconfig/network-scripts/ifcfg-ppp0
    rm /etc/wvdial.conf
    rm /etc/ppp/*secrets
Then I define the connection with neat, I try to activate it
(with the button in neat), and I get this error message on the
terminal from which I ran neat:
    /sbin/ifup: configuration for modem not found.
    Usage: ifup <device name>
Rp3 also fails. (BTW, I'm using initscripts-6.43-1).

(Also: Every time that I press the "Apply" button it asks me if I want
to change /etc/sysconfig/networking/devices/ifcfg-eth0 from mode 600 to 644,
sometimes twice, despite I am not changing the Ethernet configuration).


Comment 3 Harald Hoyer 2002-04-03 12:01:12 UTC
hmm, with the new redhat-config-network, you need newer initscripts. 
you may try to: 
$ /sbin/ifup ppp0 
per hand

Comment 4 Harald Hoyer 2002-04-03 12:02:34 UTC
the "Apply" / chmod problem is fixed in 0.9.22 and later

Comment 5 fred-m 2002-04-05 02:25:27 UTC
I remember having tried "/sbin/ifup ppp0" and it didn't work.

(I'll be out for 2 weeks -- sorry. I'll try 0.9.22 and new initscripts when I'm 
back).

Comment 6 Trond Eivind Glomsrxd 2002-04-12 00:41:19 UTC
Is this stil a problem with version 0.9.24 at http://people.redhat.com/teg/neat/ ?

Comment 7 Ngo Than 2002-04-12 22:05:38 UTC
cannot reproduce it in 0.9.24.

Comment 8 fred-m 2002-04-29 08:27:49 UTC
I tried redhat-config-network-0.9.30-1 in http://people.redhat.com/teg/neat/
under Red Hat 7.2, and the /etc/ppp/peers/ppp<x> problem (which is the objective
of this bug report) is still there. 
(All the other problems seem to have been solved).

Weird. Could it be any difference between 7.2 and Rawhide/7.3? If so, I'll
re-test it when I upgrade to 7.3.



Note You need to log in before you can comment on or make changes to this bug.