Bug 60710 - Kernel Panics after install
Kernel Panics after install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 01:15 EST by David
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 21:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2002-03-05 01:15:30 EST
Description of Problem:
After I install redhat 7.2, there will be kernel panics every time I try to 
boot into linux.  These kernel panics will happen at random times during the 
boot process

Version-Release number of selected component (if applicable):
2.4.9

How Reproducible:
Every time after install

Steps to Reproduce:
1. Install redhat 7.2
2. Boot into linux after install
3. 

Actual Results:
Kernel Panic

Expected Results:
Normal boot into linux

Additional Information:
Comment 1 Arjan van de Ven 2002-03-05 05:49:27 EST
Is this an athlon machine ?
Comment 2 David 2002-03-05 11:11:56 EST
Yes, this is an Athlon XP processor.
Comment 3 Arjan van de Ven 2002-03-05 11:15:03 EST
This looks like the athlon bios bug from 55040 then... could you look at that
bug and see if the workaround ("noathlon") fixes your problem ?
Comment 4 David 2002-03-05 16:54:11 EST
Do I just type linux noathlon at lilo prompt?  Also, I need to boot into 
console mode (runlevel 3), so should I just type linux 3 noathlon?
Comment 5 Arjan van de Ven 2002-03-05 17:00:53 EST
Yes.
If that works I recommend upgrading to the 2.4.9-31 erratum kernel which has a
workaround for the bios bug included.
Comment 6 David 2002-03-06 16:25:12 EST
Thanks a lot... the noathlon option seemed to work perfectly.  I am going to 
upgrade to kernel 2.4.18.  Do I still need the noathlon option, and if so what 
should I put in the lilo.conf file to make it permanent?
Comment 7 Arjan van de Ven 2002-03-06 16:27:14 EST
2.4.18 should have the same workaround;
if not add
append = "noathlon"
in lilo.conf
Comment 8 David 2002-03-13 08:52:06 EST
Thanks, everything seems to be working now.  What exactly is the athlon bug?
Comment 9 Arjan van de Ven 2002-03-13 09:09:24 EST
Some bioses leave the chipset in debug mode, and the chipset then "crashes" if
there's too much load on the memory bus. "noathlon" disables the kernel's fast
memcpy() implementation and therefore reducing the load the kernel puts on the
memory bus.

Note You need to log in before you can comment on or make changes to this bug.