Bug 607108 - Cannot have external monitor on the left of LVDS
Cannot have external monitor on the left of LVDS
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: 508787
  Show dependency treegraph
 
Reported: 2010-06-23 05:16 EDT by Huzaifa S. Sidhpurwala
Modified: 2010-07-16 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 00:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2010-06-23 05:16:17 EDT
RHEL6, Snapshot 6, What ever i do i cannot have external monitor on the left of LVDS. It just hangs.

1. Using gnome-display-properties when i swap the monitor with the lvds, and click on apply it hangs.
2. When i put a xorg.conf which hard codes this and when i login it again hangs.

The only way to do it, is to use xrandr. when is non-persistent.
[root@huzaifas X11]# uname -r
2.6.32-30.el6.x86_64

[root@huzaifas X11]# rpm -qa | grep xorg
xorg-x11-drv-penmount-1.4.0-5.el6.x86_64
xorg-x11-drv-mouse-1.5.0-4.el6.x86_64
xorg-x11-drv-aiptek-1.3.0-2.el6.x86_64
xorg-x11-drv-cirrus-1.3.2-1.1.el6.x86_64
xorg-x11-drv-fpit-1.3.0-5.el6.x86_64
xorg-x11-drv-ati-firmware-6.13.0-4.el6.noarch
xorg-x11-drv-elographics-1.2.3-5.el6.x86_64
xorg-x11-drv-apm-1.2.2-1.1.el6.x86_64
xorg-x11-drv-glint-1.2.4-1.1.el6.x86_64
xorg-x11-drv-ati-6.13.0-4.el6.x86_64
xorg-x11-drv-savage-2.3.1-1.1.el6.x86_64
xorg-x11-proto-devel-7.4-35.el6.noarch
xorg-x11-xkb-utils-7.4-6.el6.x86_64
xorg-x11-xinit-1.0.9-13.el6.x86_64
xorg-x11-fonts-misc-7.2-9.1.el6.noarch
xorg-x11-font-utils-7.2-10.el6.x86_64
xorg-x11-drv-vesa-2.2.1-2.el6.x86_64
xorg-x11-drv-r128-6.8.1-2.el6.x86_64
xorg-x11-drv-openchrome-0.2.904-1.el6.x86_64
xorg-x11-drv-vmware-10.16.7-2.1.el6.x86_64
xorg-x11-drv-sisusb-0.9.3-1.1.el6.x86_64
xorg-x11-drv-trident-1.3.3-1.1.el6.x86_64
xorg-x11-drv-s3virge-1.10.4-1.1.el6.x86_64
xorg-x11-drv-mga-1.4.12-1.el6.x86_64
xorg-x11-drv-qxl-0.0.12-2.1.el6.x86_64
xorg-x11-drv-mach64-6.8.2-1.1.el6.x86_64
xorg-x11-drv-nv-2.1.15-4.el6.x86_64
xorg-x11-drivers-7.3-13.2.el6.x86_64
xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.1.el6.noarch
xorg-x11-drv-void-1.3.0-4.el6.x86_64
xorg-x11-drv-wacom-0.10.5-3.el6.x86_64
xorg-x11-drv-intel-2.11.0-4.el6.x86_64
xorg-x11-drv-acecad-1.4.0-2.el6.x86_64
xorg-x11-drv-i740-1.3.2-1.1.el6.x86_64
xorg-x11-drv-dummy-0.3.3-1.el6.x86_64
xorg-x11-drv-v4l-0.2.0-3.el6.3.x86_64
xorg-x11-drv-hyperpen-1.3.0-4.el6.x86_64
xorg-x11-drv-fbdev-0.4.1-1.1.el6.x86_64
xorg-x11-drv-ast-0.89.9-1.1.el6.x86_64
xorg-x11-drv-keyboard-1.4.0-3.el6.x86_64
xorg-x11-fonts-100dpi-7.2-9.1.el6.noarch
xorg-x11-drv-evdev-2.3.2-6.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.el6.x86_64
xorg-x11-drv-tdfx-1.4.3-1.1.el6.x86_64
xorg-x11-drv-voodoo-1.2.3-1.1.el6.x86_64
xorg-x11-drv-sis-0.10.2-1.1.el6.x86_64
xorg-x11-drv-mutouch-1.2.1-5.el6.x86_64
xorg-x11-server-common-1.7.7-2.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-server-Xorg-1.7.7-2.el6.x86_64
xorg-x11-drv-synaptics-1.2.1-3.el6.x86_64
xorg-x11-drv-i128-1.3.3-1.1.el6.x86_64
xorg-x11-drv-vmmouse-12.6.5-3.el6.x86_64
xorg-x11-drv-rendition-4.2.2-4.1.el6.x86_64
xorg-x11-drv-siliconmotion-1.7.3-1.1.el6.x86_64
xorg-x11-fonts-Type1-7.2-9.1.el6.noarch
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-utils-7.4-7.el6.x86_64

[root@huzaifas X11]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
04:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 11)


This is a lenovo X200
Comment 2 RHEL Product and Program Management 2010-06-23 05:42:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Adam Jackson 2010-06-23 11:23:48 EDT
Does anything happen in dmesg when the hang occurs?  You may need to ssh into the machine to check.
Comment 4 Huzaifa S. Sidhpurwala 2010-06-24 02:21:33 EDT
I see the following in /var/log/messages

Jun 24 11:46:02 huzaifas kernel: Call Trace:
Jun 24 11:46:02 huzaifas kernel: [<ffffffff81059cc8>] ? load_balance_fair+0x1e8/0x2b0
Jun 24 11:46:02 huzaifas kernel: [<ffffffff810116e0>] ? __switch_to+0xd0/0x320
Jun 24 11:46:02 huzaifas kernel: [<ffffffff814d52c7>] __mutex_lock_slowpath+0x117/0x1a0
Jun 24 11:46:02 huzaifas kernel: [<ffffffff814d518b>] mutex_lock+0x2b/0x50
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00bbc90>] intel_idle_update+0x60/0x230 [i915]
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00bbc30>] ? intel_idle_update+0x0/0x230 [i915]
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8108a97d>] worker_thread+0x16d/0x290
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8108ff80>] ? autoremove_wake_function+0x0/0x40
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8108a810>] ? worker_thread+0x0/0x290
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8108fc26>] kthread+0x96/0xa0
Jun 24 11:46:02 huzaifas kernel: [<ffffffff810141ca>] child_rip+0xa/0x20
 
Jun 24 11:46:02 huzaifas kernel: [<ffffffff810141c0>] ? child_rip+0x0/0x20
Jun 24 11:46:02 huzaifas kernel: INFO: task Xorg:2276 blocked for more than 120 seconds.
Jun 24 11:46:02 huzaifas kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jun 24 11:46:02 huzaifas kernel: Xorg          D ffff880037084138     0  2276   2274 0x00400084
Jun 24 11:46:02 huzaifas kernel: ffff8800b3d07a48 0000000000000082 ffff880001e16840 ffff880001e16840
Jun 24 11:46:02 huzaifas kernel: 0000000000000001 0000000000000082 ffff8800b3d07a18 ffffffff8105b884
Jun 24 11:46:02 huzaifas kernel: ffff88003786f050 ffff8800b3d07fd8 00000000000103b8 ffff88003786f050
Jun 24 11:46:02 huzaifas kernel: Call Trace:
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8105b884>] ? try_to_wake_up+0x284/0x380
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8109026e>] ? prepare_to_wait+0x4e/0x80
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00a93a6>] i915_do_wait_request+0x366/0x460 [i915]
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8108ff80>] ? autoremove_wake_function+0x0/0x40
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00aa3bf>] i915_gem_object_set_to_display_plane+0xaf/0xf0 [i915]
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00b9fbd>] intel_pipe_set_base+0x12d/0x490 [i915]
Jun 24 11:46:02 huzaifas kernel: [<ffffffff812510d0>] ? idr_get_empty_slot+0x110/0x2c0
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa00910dd>] drm_crtc_helper_set_config+0x76d/0x8e0 [drm_kms_helper]
Jun 24 11:46:02 huzaifas kernel: [<ffffffff814d517e>] ? mutex_lock+0x1e/0x50
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa0059137>] drm_mode_setcrtc+0x2b7/0x3b0 [drm]
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa004bd3a>] drm_ioctl+0x32a/0x480 [drm]
Jun 24 11:46:02 huzaifas kernel: [<ffffffffa0058e80>] ? drm_mode_setcrtc+0x0/0x3b0 [drm]
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8117a6f2>] vfs_ioctl+0x22/0xa0
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8117a894>] do_vfs_ioctl+0x84/0x580
Jun 24 11:46:02 huzaifas kernel: [<ffffffff8117ae11>] sys_ioctl+0x81/0xa0
Jun 24 11:46:02 huzaifas kernel: [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
Comment 5 Dave Airlie 2010-06-24 23:20:56 EDT
this should be fixed with kernel 2.6.32-33 or newer, please try with -37.
Comment 7 Huzaifa S. Sidhpurwala 2010-07-16 00:50:10 EDT
works for me with the latest kernel.
Comment 8 Christopher Aillon 2010-07-16 00:50:58 EDT
Closing based on above comment.

Note You need to log in before you can comment on or make changes to this bug.