Bug 60720 - rpmdb: damaged header instance #946 retrieved, skipping
rpmdb: damaged header instance #946 retrieved, skipping
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
http://www.futuremedtec.is/rpmdb.tar.gz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 10:39 EST by Arnor Sigfusson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 10:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnor Sigfusson 2002-03-05 10:39:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
rpmdb: damaged header instance #946 retrieved, skipping
This message appears every time I run rpm.  I am using rpm-4.0.3-1.03 and I 
tried rpm --rebuilddb and got :
rpmdb: damaged header instance #946 retrieved, skipping.Segmentation fault

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -q rpm
2.rpm --rebuilddb
3.
	

Actual Results:  rpmdb: damaged header instance #946 retrieved, skipping.
Segmentation fault

Additional info:
Comment 1 Jeff Johnson 2002-03-10 10:42:55 EST
Instances #946 and #948 were bad. I've deleted, find a
copy of your fixed rpm/Packages at
	http://people.redhat.com/jbj/rpmdb-60720-FIX.tar.gz
Download and install by doing (as root)
	cd /var/lib
	mv rpm/Packages rpm/Packages-ORIG
	tar xzvf rpmdb-60720-FIX.tar.gz
	rpm --rebuilddb -vv
Comment 2 Arnor Sigfusson 2002-03-11 06:55:49 EST
Thank you for the resonse.  Unfortunately the link: 
http://people.redhat.com/jbj/rpmdb-60720-FIX.tar.gz
 leads nowhere, I just get page not found.

Arnor
Comment 3 Jeff Johnson 2002-03-11 07:37:31 EST
Apologies, ftp://, not http://

Note You need to log in before you can comment on or make changes to this bug.