Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607280 - Fix crashes in desktop-effects
Fix crashes in desktop-effects
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: desktop-effects (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Owen Taylor
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 13:07 EDT by Owen Taylor
Modified: 2010-11-10 15:07 EST (History)
3 users (show)

See Also:
Fixed In Version: desktop-effects-0.8.4-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2010-06-23 13:07:53 EDT
There are several crashes reported during OpenGL detection in desktop-effects that have easy, safe fixes:

 Bug 533807 - Crash in glXDestroyContext
 http://git.fedorahosted.org/git/?p=desktop-effects.git;a=commit;h=1e96aac70b3290a954fa29196a4dbf93f2c3578a
 Bug 574500 - BadMatch from XCreateWindow
 http://git.fedorahosted.org/git/?p=desktop-effects.git;a=commit;h=d822283c5bc0e8a6bc24bff8fab6c78f319b6b50

The second one is especially common and occurs any time you run desktop-effects after configuring 16bpp graphics. We should pull these fixes in for RHEL6.
Comment 6 Owen Taylor 2010-07-13 13:04:19 EDT
Having tried it, I don't think it makes sense to try and reproduce in gdb. The poor handling of optimized code in gdb makes it really confusing and unpredictable, and any instructions I could give would reproduce it both with and without the fix.

Because the same instructions that initialize an uninitialized variable to a junk value will also reinitialize an initialized variable to a junk value.

However, it was really good you asked for this, since in investigating, I found that the patch was not correctly included in the RPM!

Will build a better version immediately.
Comment 7 Owen Taylor 2010-07-13 13:30:42 EDT
Version with the relevant patch actually applied is now built.
Comment 9 Owen Taylor 2010-07-13 14:08:45 EDT
It would be good to test that desktop-effects properly works if mesa-dri-drivers is removed (with rpm -e --nodeps if necessary.) It should display a message on startup that GL is not available.

That will test the code path that was changed.

But there's nothing I can suggest that will give before/after verification that it crashes with the old packages and not with the new packages.
Comment 10 Lubos Kocman 2010-07-15 04:36:13 EDT
Verified (according to Comment 9) on:

desktop-effects-0.8.4-6.el6


Getting (after removing mesa-dri-drivers and logout):

Accelerated 3D graphics is not available
Desktop effects require hardware 3D support.
Comment 11 releng-rhel@redhat.com 2010-11-10 15:07:31 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.