Bug 60730 - 'ps' displays numeric id for usernames > 8 characters
'ps' displays numeric id for usernames > 8 characters
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 13:36 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 13:36:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-05 13:36:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
'ps -u' etc. shows numeric uid if process owner login name is more than 8
characters.

Version-Release number of selected component (if applicable):
procps-2.0.7-11


How reproducible:
Always

Steps to Reproduce:
1.adduser abcdefghi
2.su - abcdefghi
3.ps -u
	

Actual Results:  
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
503       2708  0.5  0.3  2420 1284 pts/0    S    13:25   0:00 -bash
503       2756  0.0  0.1  2612  728 pts/0    R    13:25   0:00 ps -u


Expected Results:  
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
abcdefghi 2708  0.5  0.3  2420 1284 pts/0    S    13:25   0:00 -bash
abcdefghi 2756  0.0  0.1  2612  728 pts/0    R    13:25   0:00 ps -u


Additional info:

Debian patched this to show a substring -- e.g. 'abcdefg' -- not sure if that's
the Right Thing (tm) or not...
Comment 1 Michael K. Johnson 2002-03-27 18:31:01 EST
I think that showing a substring is a bug in that case; it could
really confuse scripts that should not be confused by numeric IDs.

So I'm going to close this as "not a bug".

Note You need to log in before you can comment on or make changes to this bug.