This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 607387 - [abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:278e33f7e96e2931580a378ac42...
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-24 00:59 UTC by Alexandru Barborica
Modified: 2010-08-22 13:01 UTC (History)
3 users (show)

Fixed In Version: latest
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 08:08:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (69.33 KB, text/plain)
2010-06-24 00:59 UTC, Alexandru Barborica
no flags Details

Description Alexandru Barborica 2010-06-24 00:59:04 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.6/firefox http://www.whiteimage.net/clients/wlm/unsubscribe.php?vc=MTQyNCMjMjk3MjgjIzg2MDA4IyNibGFja2xvcmQ5QGhvdG1haWwuY29t
comment: I tried using the facebook java uploader. It loads but crashes when trying to upload.
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.6/firefox
global_uuid: 278e33f7e96e2931580a378ac422f02d2e0f0606
kernel: 2.6.33.5-124.fc13.x86_64
package: firefox-3.6.3-4.fc13
rating: 4
reason: Process /usr/lib64/firefox-3.6/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.Use Facebook java uploader
2.Select multiple photos and upload
3.

Comment 1 Alexandru Barborica 2010-06-24 00:59:07 UTC
Created attachment 426424 [details]
File: backtrace

Comment 2 d. johnson 2010-08-17 18:41:27 UTC
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update' or using the graphical updater, Software Update.


Disable extensions, plugins and non-default themes. Clear cookies and cache. Exit the browser completely.  Then restart the browser and attempt to replicate the crash.


#2  <signal handler called>
No symbol table info available.
#3  0x00000038eaa329a5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = 6706
        selftid = 6706
#4  0x00000038eaa34185 in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x38ee2b9210, 
            sa_sigaction = 0x38ee2b9210}, sa_mask = {__val = {244455843006, 
    140734078426448, 249, 140734078426688, 244454939710, 206158430232, 
    140734078426704, 140734078426480, 244454846792, 206158430256, 
    140734078426728, 140445326139776, 10, 140446045257792, 6706, 
    140734078458518}}, sa_flags = -357298739, sa_restorer = 0x38ee2b9049}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#5  0x00000038eaa2b925 in __assert_fail (assertion=
    0x38ee2b9210 "(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)", file=<value optimized out>, line=249, function=<value optimized out>)
    at assert.c:81
        buf = 
    0x7fbbf9c66180 "firefox: xcb_io.c:249: process_responses: Assertion `(((long) (dpy->last_request_read) - (long) (dpy->request)) <= 0)' failed.\n"
#6  0x00000038ee24d0dd in process_responses (dpy=0x7fbc24985000, 
    wait_for_first_event=0, current_error=0x0, current_request=0)
    at xcb_io.c:249
        reply = 0x38ec25f303
        event = 0x0
        error = 0x7fbc058a3000
        c = 0x7fbc24987000
        __PRETTY_FUNCTION__ = "process_responses"
#7  0x00000038ee24d947 in _XEventsQueued (dpy=0x7fbc24985000, 
    mode=<value optimized out>) at xcb_io.c:263
No locals.
#8  0x00000038ee23617d in XPending (dpy=0x7fbc24985000) at Pending.c:56
        ret_val = <value optimized out>
#9  0x00000038f1a5d4c2 in gdk_event_prepare (source=<value optimized out>, 




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 d. johnson 2010-08-22 13:01:52 UTC
Thank you Alexandru, I'm glad to see updating fixed the problem.


Note You need to log in before you can comment on or make changes to this bug.