Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607479 - SELinux is preventing /usr/sbin/lsof "getattr" access on packet_socket.
SELinux is preventing /usr/sbin/lsof "getattr" access on packet_socket.
Status: CLOSED DUPLICATE of bug 607883
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
Milos Malik
setroubleshoot_trace_hash:c276a23e819...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 04:11 EDT by Matěj Cepl
Modified: 2012-10-15 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 03:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2010-06-24 04:11:25 EDT
Souhrn:

SELinux is preventing /usr/sbin/lsof "getattr" access on packet_socket.

Podrobný popis:

[SELinux je v tolerantním režimu. Přístup byl povolen.]

SELinux denied access requested by lsof. It is not expected that this access is
required by lsof and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Další informace:

Kontext zdroje                system_u:system_r:ipsec_mgmt_t:s0
Kontext cíle                 system_u:system_r:NetworkManager_t:s0-s0:c0.c1023
Objekty cíle                 packet_socket [ packet_socket ]
Zdroj                         lsof
Cesta zdroje                  /usr/sbin/lsof
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          lsof-4.82-1.1.el6
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.7.19-27.el6
Selinux povolen               True
Typ politiky                  targeted
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux johanka.ceplovi.cz 2.6.32-37.el6.x86_64 #1
                              SMP Sun Jun 20 19:29:35 EDT 2010 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               Čt 24. červen 2010, 07:42:15 CEST
Naposledy viděno             Čt 24. červen 2010, 07:42:15 CEST
Místní ID                   88fd89f3-205f-4b05-b64b-46fa9fd1b543
Čísla řádků              

Původní zprávy auditu      

node=johanka.ceplovi.cz type=AVC msg=audit(1277358135.593:486): avc:  denied  { getattr } for  pid=13166 comm="lsof" path="socket:[193423]" dev=sockfs ino=193423 scontext=system_u:system_r:ipsec_mgmt_t:s0 tcontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tclass=packet_socket

node=johanka.ceplovi.cz type=SYSCALL msg=audit(1277358135.593:486): arch=c000003e syscall=4 success=yes exit=0 a0=1f4c820 a1=7fff315dff10 a2=7fff315dff10 a3=ffffffff items=0 ppid=13160 pid=13166 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="lsof" exe="/usr/sbin/lsof" subj=system_u:system_r:ipsec_mgmt_t:s0 key=(null)



Hash String generated from  catchall,lsof,ipsec_mgmt_t,NetworkManager_t,packet_socket,getattr
audit2allow suggests:

#============= ipsec_mgmt_t ==============
allow ipsec_mgmt_t NetworkManager_t:packet_socket getattr;
Comment 2 RHEL Product and Program Management 2010-06-24 04:32:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Miroslav Grepl 2010-06-25 03:35:53 EDT

*** This bug has been marked as a duplicate of bug 607883 ***

Note You need to log in before you can comment on or make changes to this bug.