Bug 607509 - Firefox Sync (Weave) doesn't work
Summary: Firefox Sync (Weave) doesn't work
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-24 09:46 UTC by Rui Matos
Modified: 2010-07-01 09:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 09:58:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rui Matos 2010-06-24 09:46:20 UTC
I have installed the latest packages for firefox:

xulrunner-1.9.2.4-1.fc13.i686
xulrunner-devel-1.9.2.4-1.fc13.i686
firefox-3.6.4-1.fc13.i686

and the upstream Firefox Sync 1.3.1 extension. I have also tried with an upstream Firefox 3.6.4 build installed under $HOME which also doesn't work in the same way.

I have SELinux in permissive mode.

Here's the weave log:

2010-06-24 10:34:57	Service.Main         INFO	Loading Weave 1.3.1
2010-06-24 10:34:57	Engine.Bookmarks     DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.Forms         DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.History       DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.Passwords     DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.Prefs         DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.Tabs          DEBUG	Engine initialized
2010-06-24 10:34:57	Engine.Tabs          DEBUG	Resetting tabs last sync time
2010-06-24 10:34:57	Service.Main         INFO	Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100622 Fedora/3.6.4-1.fc13 Firefox/3.6.4
2010-06-24 10:34:57	Service.Util         WARN	Component @labs.mozilla.com/Weave/Crypto;1 doesn't exist on this platform.
2010-06-24 10:34:57	Service.Util         WARN	Component @labs.mozilla.com/Weave/Crypto;2 doesn't exist on this platform.
2010-06-24 10:34:57	Service.Main         DEBUG	Crypto check failed: TypeError: Svc.Crypto is undefined
2010-06-24 10:34:57	Service.Main         ERROR	Could not load the Weave crypto component. Disabling Weave, since it will not work correctly.
2010-06-24 10:34:57	Service.Main         INFO	Weave Sync disabled

Comment 1 Rui Matos 2010-07-01 09:58:43 UTC
Upgraded today to Sync 1.4 and it is working OK with the Fedora packages. Closing this.


Note You need to log in before you can comment on or make changes to this bug.