Bug 60751 - swapoff -a will sometimes return without unmounting any swap
Summary: swapoff -a will sometimes return without unmounting any swap
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-05 22:56 UTC by Norm Murray
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 18:44:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Norm Murray 2002-03-05 22:56:42 UTC
Description of Problem: swapoff -a will sometimes return without unmounting any
swap
swapoff against partitions/files will unmount those particular files/partitions.

When everything is unmounted, swapon -a will restore the system 

At the moment I don't have a reproducible test case, but am working to find one.

Comment 1 Elliot Lee 2002-03-27 18:44:10 UTC
Need a reproducible test case...

Comment 2 Frank Hirtz 2002-03-27 23:30:14 UTC
This has reportedly been fixed in the version of mount which shipped with 7.2
(mount-2.11g-5). The problem has not been reported since this upgrade.


Note You need to log in before you can comment on or make changes to this bug.