Bug 607515 - support btrfs
support btrfs
Status: CLOSED DUPLICATE of bug 616694
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cong Wang
Lubos Kocman
:
Depends On:
Blocks: 740278 751927
  Show dependency treegraph
 
Reported: 2010-06-24 05:52 EDT by CAI Qian
Modified: 2013-09-29 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-99_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 740278 (view as bug list)
Environment:
Last Closed: 2010-11-11 09:46:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.90 KB, patch)
2010-06-28 03:50 EDT, Cong Wang
no flags Details | Diff

  None (edit)
Description CAI Qian 2010-06-24 05:52:38 EDT
Description of problem:
# cat /etc/kdump.conf

btrfs /dev/mapper/VolGroup-lv_root
default shell
core_collector makedumpfile -c -d 31

# service  kdump restart
Stopping kdump:                                            [  OK  ]
Detected change(s) the following file(s):
  
  /etc/kdump.conf
Rebuilding /boot/initrd-2.6.32-37.el6.x86_64kdump.img
/etc/kdump.conf: Unsupported type btrfs
Failed to run mkdumprd
Starting kdump:

This is because the check utility is called /sbin/btrfsck not fsck.btrfs.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-84.el6
Comment 1 CAI Qian 2010-06-24 05:59:27 EDT
I suppose we need either to fix busybox to include btrfs support or bring the btrfsck in. Otherwise, the error occurred during the dumping process,

msh: can't execute 'btrfsck': No such file or directory
Comment 2 Cong Wang 2010-06-28 03:50:35 EDT
Created attachment 427334 [details]
Proposed patch

Does this patch work?
Comment 3 CAI Qian 2010-06-28 04:57:07 EDT
Passed my test.
Comment 6 Lubos Kocman 2010-07-22 09:43:48 EDT
Verified on kexec-tools-2.0.0-116.el6

Works perfectly for me now. Thank you guys
Comment 7 releng-rhel@redhat.com 2010-11-11 09:46:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 8 Lubos Kocman 2011-09-23 06:30:35 EDT

*** This bug has been marked as a duplicate of bug 616694 ***

Note You need to log in before you can comment on or make changes to this bug.