Bug 607586 - s-c-d doesn't show proper resolution for HD display (Lenovo W510)
Summary: s-c-d doesn't show proper resolution for HD display (Lenovo W510)
Status: CLOSED DUPLICATE of bug 607594
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-display
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-24 12:48 UTC by David Kovalsky
Modified: 2014-03-31 23:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-07-23 14:59:41 UTC


Attachments (Terms of Use)
xorg.conf (1.18 KB, text/plain)
2010-06-24 12:48 UTC, David Kovalsky
no flags Details
system-config-display screenshot (37.61 KB, image/png)
2010-06-24 12:52 UTC, David Kovalsky
no flags Details
xorg.conf found right after install (801 bytes, text/plain)
2010-06-26 20:55 UTC, David Kovalsky
no flags Details
Xorg.0.log (40.32 KB, text/plain)
2010-06-26 20:56 UTC, David Kovalsky
no flags Details
/var/log/messages with NetworkManager messages cut out (50.10 KB, text/plain)
2010-06-26 21:04 UTC, David Kovalsky
no flags Details

Description David Kovalsky 2010-06-24 12:48:57 UTC
Created attachment 426554 [details]
xorg.conf

I've got a Lenovo W510 with display supporting 1920x1080. 

The display + graphics driver wasn't properly autodetected, I'll file a different bug for that. 

When I manually select 'nv' driver, generic LCD monitor 1920x1080, native resolution of 1920x1080, xrandr confirms and X start:

[test@dhcp-29-96 ~]$ xrandr -q
 SZ:    Pixels          Physical       Refresh
*0   1920 x 1080   ( 344mm x 193mm )  *60   50  
Current rotation - normal
Current reflection - none
Rotations possible - normal 
Reflections possible - none


But system-config-display is showing only 1680x1050 (see screenshot).

kernel-2.6.18-194.3.1.el5
system-config-display-1.0.48-2.el5
xorg-x11-server-Xorg-1.1.1-48.76.el5_5.1
xorg-x11-drv-nv-2.1.15-3.el5

Comment 1 David Kovalsky 2010-06-24 12:52:04 UTC
Created attachment 426557 [details]
system-config-display screenshot

Comment 2 Matěj Cepl 2010-06-24 16:48:48 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 David Kovalsky 2010-06-26 20:54:51 UTC
Hi Matej, 

xorg conf is attached (see the first comment). 

Attaching the autogenerated one (default after install), xorg.log and messages.

Comment 4 David Kovalsky 2010-06-26 20:55:39 UTC
Created attachment 427132 [details]
xorg.conf found right after install

Comment 5 David Kovalsky 2010-06-26 20:56:42 UTC
Created attachment 427133 [details]
Xorg.0.log

Comment 6 David Kovalsky 2010-06-26 21:04:16 UTC
Created attachment 427134 [details]
/var/log/messages with NetworkManager messages cut out

Comment 7 Matěj Cepl 2010-07-23 14:59:41 UTC
In my opinion this is also problem of the xorg system itself. Closing as duplicate of bug 607594

*** This bug has been marked as a duplicate of bug 607594 ***


Note You need to log in before you can comment on or make changes to this bug.