Bug 607594 - Lenovo W510: proper driver and resolution not properly detected
Lenovo W510: proper driver and resolution not properly detected
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ben Skeggs
desktop-bugs@redhat.com
: Triaged
: 607586 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 09:02 EDT by David Kovalsky
Modified: 2014-03-31 19:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 13:21:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log - NV (61.81 KB, text/plain)
2010-06-24 09:02 EDT, David Kovalsky
no flags Details
/var/log/Xorg.0.log - VESA (56.38 KB, text/plain)
2010-08-04 09:46 EDT, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2010-06-24 09:02:05 EDT
Created attachment 426564 [details]
/var/log/Xorg.0.log - NV

Installed 5.5 on Lenovo W510, but the default driver is Vesa (when it should be 'nv') and resolution is 800x600 instead of 1920x1080. 

Display is not detected at all. 

[root@dhcp-29-96 ~]# lspci|grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0a3c (rev a2)

[root@dhcp-29-96 ~]# lspci -n|grep 01:00.0
01:00.0 0300: 10de:0a3c (rev a2)

Xorg.log attached. 

Let me know what kind of data would be helpful to you :)
Comment 3 Matěj Cepl 2010-07-23 10:59:41 EDT
*** Bug 607586 has been marked as a duplicate of this bug. ***
Comment 7 David Kovalsky 2010-08-04 09:46:30 EDT
Created attachment 436543 [details]
/var/log/Xorg.0.log - VESA
Comment 8 RHEL Product and Program Management 2010-08-09 15:46:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 Adam Jackson 2012-04-20 13:21:27 EDT
nv is intentionally not used by default on chipsets where DisplayPort might be attached, because nv doesn't (and won't) support DisplayPort.

No further hardware enablement updates are planned for RHEL5's X stack.  If RHEL6's with the nouveau driver has issues on this chipset, please file a new bug against RHEL6.

Note You need to log in before you can comment on or make changes to this bug.