Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607751 - [abrt] crash in thunderbird-3.0.4-2.fc12: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in thunderbird-3.0.4-2.fc12: Process /usr/lib64/thunderbird-3.0/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:df6f970105d30029629b0c71935...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 13:48 EDT by Jonathan Larmour
Modified: 2010-08-22 02:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 02:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (110.29 KB, text/plain)
2010-06-24 13:48 EDT, Jonathan Larmour
no flags Details

  None (edit)
Description Jonathan Larmour 2010-06-24 13:48:20 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
component: thunderbird
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
global_uuid: df6f970105d30029629b0c71935ace9a8521201d
kernel: 2.6.32.14-127.fc12.x86_64
package: thunderbird-3.0.4-2.fc12
rating: 4
reason: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
The message got sent successfully. There seemed to be a delay in copying to the Sent folder - I don't know if that's related, although it was successfully placed in the Sent folder. Then thunderbird SEGV'd.

How to reproduce
-----
Here's what I did, although I repeated it and wasn't able to reproduce it a second time:
1. I selected two mails from my Sent folder
2. Then chose Message->Forward As->Attachment
3. wrote some blurb in the message body and hit Send.
Comment 1 Jonathan Larmour 2010-06-24 13:48:23 EDT
Created attachment 426663 [details]
File: backtrace
Comment 2 d. johnson 2010-08-20 13:31:02 EDT
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update' or using the graphical updater, Software Update.


Disable any extensions, plugins and non-default themes.  Exit cleanly and restart thunderbird.  Are you able to replicate the crash?


#2  <signal handler called>
No symbol table info available.
#3  0x00000033fce3ec9d in GetGCThingFlags (trc=0x7fffe1bef200, thing=
    0x7fdf1410d480, kind=0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsgc.cpp:1130
        a = 0x7fdf1410dfe0
#4  JS_CallTracer (trc=0x7fffe1bef200, thing=0x7fdf1410d480, kind=0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsgc.cpp:2712
        rt = 0x7fdf247a3000
        a = <value optimized out>
        cx = 0x7fdf07bb2c00
        index = <value optimized out>
        flagp = <value optimized out>
#5  0x00000033fce548a5 in js_TraceObject (trc=0x7fffe1bef200, obj=
    0x7fdf11e41b00)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsobj.cpp:5805
        clasp = <value optimized out>
        i = 26
        cx = <value optimized out>
        scope = <value optimized out>
        traceScope = <value optimized out>
        sprop = <value optimized out>
        nslots = 30
        v = <value optimized out>
#6  0x00000033fce3ed7b in JS_CallTracer (trc=0x7fffe1bef200, 
    thing=<value optimized out>, kind=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsgc.cpp:2738
        stackDummy = 32735
        rt = <value optimized out>
        a = <value optimized out>
        cx = 0x7fdf07bb2c00
        index = <value optimized out>
        flagp = <value optimized out>
#7  0x00000033fce548a5 in js_TraceObject (trc=0x7fffe1bef200, obj=
    0x7fdf12ca4900)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsobj.cpp:5805
        clasp = <value optimized out>
        i = 43
        cx = <value optimized out>
        scope = <value optimized out>
        traceScope = <value optimized out>
        sprop = <value optimized out>
        nslots = 46
        v = <value optimized out>
#8  0x00000033fce3ed7b in JS_CallTracer (trc=0x7fffe1bef200, 
    thing=<value optimized out>, kind=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/js/src/jsgc.cpp:2738
        stackDummy = 32735
        rt = <value optimized out>
        a = <value optimized out>
        cx = 0x7fdf07bb2c00
        index = <value optimized out>
        flagp = <value optimized out>
#9  0x00007fdf21f00853 in TraceScopeJSObjects (trc=0x7fffe1bef200, scope=




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Jonathan Larmour 2010-08-21 18:51:41 EDT
This problem has only occurred once. I was hoping you'd be able to use the backtrace to look into the issue if you wanted to, but if you don't, that's fine - since I couldn't reproduce the issue with thunderbird 3.0.4, and still can't with the updated 3.0.6, you may prefer to just close the bug in that case. I'll leave it up to you.
Comment 4 d. johnson 2010-08-22 02:09:45 EDT
Now that you have upgraded versions, I'm going to close this one out.  The problem above was likely fixed.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.