Bug 607760 - ip=eth#:dhcp does not appear to be working
ip=eth#:dhcp does not appear to be working
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 14:13 EDT by Hans de Goede
Modified: 2010-06-25 08:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 08:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsinitrd on initramfs with a minimal packageset (151.99 KB, text/plain)
2010-06-25 05:43 EDT, Hans de Goede
no flags Details
rpm -qa on minimal install (6.65 KB, text/plain)
2010-06-25 05:44 EDT, Hans de Goede
no flags Details
dracut -v output on minimal system (91.02 KB, text/plain)
2010-06-25 05:44 EDT, Hans de Goede
no flags Details
lsinitrd on initramfs with a default packageset (161.15 KB, text/plain)
2010-06-25 05:45 EDT, Hans de Goede
no flags Details
rpm -qa on a default install (32.87 KB, text/plain)
2010-06-25 05:45 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2010-06-24 14:13:10 EDT
When trying to boot an installation with / on an iscsi disk things fail if ip=eth#:dhcp is used, if it gets replaced with an ip=..... static configuration for the same eth# and the rest of the cmdline is identical things work fine.

This is a simple installation using 1 iscsi disk with default anaconda auto-partitioning on the iscsi disk.

I'm wondering if the issue I'm seeing may be related to device renaming, dracut seems to detect another eth0 then the card from which I'm booting, which was eth0 in anaconda. So I know have an eth0 and an eth0-renamed. OTOH static IP works fine and the parts of the involved code path which do the actual renaming are the same for static and dhcp

I did notice in a previous test run that if I manually do a /sbin/ifup eth0 under the dracut shell (when starting with rdshell) net.eth0.dhlease etc files pop up under /tmp and look good, but the output of ip addr still shows the interface as unconfigured ??
Comment 1 Harald Hoyer 2010-06-25 04:52:41 EDT
did you specify ifname?

$ man dracut
...
ifname=<interface>:<MAC>
Assign network device name <interface> (ie eth0) to the NIC with MAC <MAC>.   Note  letters  in  the  MAC-address must be lowercase!  Note that if you use this option you must specify an ifname= argument for all interfaces used  in  ip=  or  fcoe=  arguments. This parameter can be specified multiple times.


did specify ifname for all interfaces???
Comment 2 Hans de Goede 2010-06-25 05:06:15 EDT
(In reply to comment #1)
> did you specify ifname?
> 

Yes anaconda which generated the cmdline specifies ifname

> $ man dracut
> ...
> ifname=<interface>:<MAC>
> Assign network device name <interface> (ie eth0) to the NIC with MAC <MAC>.  
> Note  letters  in  the  MAC-address must be lowercase!  Note that if you use
> this option you must specify an ifname= argument for all interfaces used  in 
> ip=  or  fcoe=  arguments. This parameter can be specified multiple times.
> 
> 
> did specify ifname for all interfaces???    

No only for the one in use. But this is handled properly by dracut other ones which might get in the way get renamed out of the way by a special rule.

Update:

This happened with a minimal install. I tried again with a regular install and it works fine there, so there seems to be some missing bits in the minimal install case.
Comment 3 Hans de Goede 2010-06-25 05:43:50 EDT
Created attachment 426815 [details]
lsinitrd on initramfs with a minimal packageset
Comment 4 Hans de Goede 2010-06-25 05:44:14 EDT
Created attachment 426816 [details]
rpm -qa on minimal install
Comment 5 Hans de Goede 2010-06-25 05:44:56 EDT
Created attachment 426818 [details]
dracut -v output on minimal system
Comment 6 Hans de Goede 2010-06-25 05:45:19 EDT
Created attachment 426820 [details]
lsinitrd on initramfs with a default packageset
Comment 7 Hans de Goede 2010-06-25 05:45:57 EDT
Created attachment 426822 [details]
rpm -qa on a default install
Comment 8 Hans de Goede 2010-06-25 08:09:07 EDT
And today I cannot reproduce this anymore ... ???

Closing as worksforme.

Note You need to log in before you can comment on or make changes to this bug.