Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 607762 - anaconda writes wrong ip= cmdline for dracut for static ip configuration
anaconda writes wrong ip= cmdline for dracut for static ip configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 14:19 EDT by Hans de Goede
Modified: 2010-11-10 14:49 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.54-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-06-24 14:19:46 EDT
anaconda writes wrong ip= cmdline for dracut for static ip configuration, this results a not booting system in case of an installation to a network based (ie iscsi) disk.

This is likely caused by /etc/sysconfig/network-scripts/ifcfg-* no longer containing a NETMASK string but rather a PREFIX string.

Radek, do you have any ideas how to get a good old netmask with this change in place, and/or a pre-existing python function to convert between a prefix and a netmask ?
Comment 1 Radek Vykydal 2010-06-25 03:09:59 EDT
(In reply to comment #0)

 
> Radek, do you have any ideas how to get a good old netmask with this change in
> place, and/or a pre-existing python function to convert between a prefix and a
> netmask ?    

I noticed that we have isys.prefix2netmask and isys.netmask2prefix.
Comment 2 Hans de Goede 2010-06-25 05:37:57 EDT
A patch for this is ready and has been tested, adding devel ack. Note to qa I've ibft boot capable hardware and can verify this.
Comment 3 RHEL Product and Program Management 2010-06-25 05:42:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Hans de Goede 2010-06-25 06:10:49 EDT
This is fixed in anaconda-13.21.54-1, moving to modified.
Comment 6 Alexander Todorov 2010-07-19 06:24:24 EDT
With snap #7 ip= parameter specifies the netmask as well. Moving to VERIFIED.
Comment 7 releng-rhel@redhat.com 2010-11-10 14:49:10 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.