Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607869 - IO is stuck due to active device that moved to suspend mode and never resumed
IO is stuck due to active device that moved to suspend mode and never resumed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Ben Marzinski
Barry Donahue
:
Depends On: 584742
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 23:54 EDT by Ben Marzinski
Modified: 2010-11-10 15:11 EST (History)
19 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-23.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 584742
Environment:
Last Closed: 2010-11-10 15:11:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ben Marzinski 2010-06-25 00:02:34 EDT
This bug exists on RHEL6 as well. I already have a patch to fix it.
Comment 2 RHEL Product and Program Management 2010-06-25 00:02:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ben Marzinski 2010-06-28 18:42:29 EDT
multipath now uses the resize code that doesn't set noflush for reloads because of changed size.
Comment 4 Ben Marzinski 2010-06-28 19:09:10 EDT
You can pick up packages with this fix at http://people.redhat.com/bmarzins/device-mapper-multipath/rpms/RHEL6/
Comment 6 Barry Donahue 2010-09-13 14:18:34 EDT
Verified on snap-13 on storageqe-04. Upgraded a LUN from 30GB to 40GB.
Comment 7 releng-rhel@redhat.com 2010-11-10 15:11:29 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.