Bug 60787 - timconfig doesn't consistently use %{_mandir}
timconfig doesn't consistently use %{_mandir}
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: timeconfig (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-06 13:28 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 13:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to man/Makefile to use macro "mandir" for manpage installation location (637 bytes, patch)
2002-03-06 13:36 EST, Need Real Name
no flags Details | Diff
Patch to spec file to pass mandir macro to make at install time (303 bytes, patch)
2002-03-06 13:37 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2002-03-06 13:28:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.8+) Gecko/20020226

Description of problem:
The timeconfig man/Makefile file don't use the %{_mandir} macro, it is hardcoded
to "/usr/share/man".  However, the spec file does use %{_mandir} in the %files
section.  If %{_mandir} is not equal to /usr/share/man, building from source RPM
will fail, unable to locate the man pages.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Change %{_mandir} to /usr/man
2.  Rebuild the timeconfig package.

	

Actual Results:  Build fails because manpages are installed in
$RPM_BUILD_ROOT/usr/share/man, but the spec file looks for them in
$RPM_BUILD_ROOT/usr/man.


Expected Results:  Successful build.

Additional info:
Comment 1 Need Real Name 2002-03-06 13:36:06 EST
Created attachment 47623 [details]
Patch to man/Makefile to use macro "mandir" for manpage installation location
Comment 2 Need Real Name 2002-03-06 13:37:20 EST
Created attachment 47624 [details]
Patch to spec file to pass mandir macro to make at install time
Comment 3 Trond Eivind Glomsrxd 2002-03-18 17:14:45 EST
timeconfig-3.2.7-1 has a fix for this.

Note You need to log in before you can comment on or make changes to this bug.