Bug 607954 - [abrt] crash in liferea-1:1.6.3-1.fc13: raise: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in liferea-1:1.6.3-1.fc13: raise: Process /usr/bin/liferea was k...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1656a236fce9ddc59260b48177b...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-25 09:40 UTC by Richard Kennedy
Modified: 2010-10-13 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 16:41:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (43.53 KB, text/plain)
2010-06-25 09:40 UTC, Richard Kennedy
no flags Details

Description Richard Kennedy 2010-06-25 09:40:31 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: liferea
component: liferea
crash_function: raise
executable: /usr/bin/liferea
global_uuid: 1656a236fce9ddc59260b48177b1252b8a3d8237
kernel: 2.6.35-rc3-00011-g45de103
package: liferea-1:1.6.3-1.fc13
rating: 4
reason: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

comment
-----
liferea crashs everyday on one site or another and it has become mainly un-useable.
I have uncheck the browser plugins option in the prefs but that doesn't help, and the liferea mailing list say that option doesn't seem to work properly. 

if I run liferea from a shell I get lots these of messages before it crashes

(liferea:2194): libsoup-CRITICAL **: soup_cookie_domain_matches: assertion `host != NULL' failed

How to reproduce
-----
1.access rss feed item -- in this case from http://www.randi.org/site/index.php?format=feed&type=rss
2. crash! ( or sometimes just a lockup!)
3.

Comment 1 Richard Kennedy 2010-06-25 09:40:34 UTC
Created attachment 426814 [details]
File: backtrace

Comment 2 Lars Schotte 2010-06-28 14:06:00 UTC
Package: liferea-1:1.6.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just crashes
2.
3.


Comment
-----
nothing

Comment 3 Lars Schotte 2010-06-28 19:08:51 UTC
Package: liferea-1:1.6.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just crashes
2.
3.


Comment
-----
nothing

Comment 4 Lars Schotte 2010-06-28 19:18:11 UTC
Package: liferea-1:1.6.3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.just crashes
2.
3.


Comment
-----
nothing

Comment 5 Richard Kennedy 2010-06-29 13:31:09 UTC
At least part of this problem seems to be caused by an advert served from ads.pheedo.com.

I've mapped ads.pheedo.com to 127.0.0.1 in my hosts file and so far everything is working correctly, no lockups or crashes.

Comment 6 Steven M. Parrish 2010-07-13 22:26:37 UTC
Liferea 1.6.4 has been pushed to stable.  Please upgrade to this latest version and see if it corrects this issue.  If there is no update to this bug within 30 days will close as WORKSFORME.

Thanks

Comment 7 Richard Kennedy 2010-07-21 21:09:34 UTC
I have had only one crash with the new version, so it does seem much more stable and usable. The newer version is much improved and very usable day to day.

thanks

Comment 8 Steven M. Parrish 2010-10-13 16:41:35 UTC
Liferea 1.6.5 has been submitted for testing on F12/F13/F14.  Closing this bug for now.  Please install the new update and if the problem returns feel free to reopen this report with additional information


Note You need to log in before you can comment on or make changes to this bug.