Bug 60800 - Package depedencies on Perl Errata ( perl-5.6.1-26.72.3)
Package depedencies on Perl Errata ( perl-5.6.1-26.72.3)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
triage|leonardjo|closed|notabug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-06 16:59 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 12:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-06 16:59:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
You guys are required additional packages to be installed to support an errata.
 Please don't do this.  This is what got Microsoft in trouble.  If I'm going to
update the perl RPM, why do I have to install additional RPMs to do so?  I
reported a similar problem at bug # 57668.  These are the things you should
change in different rev's of the OS, not in the packages themselves.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh perl-5.6.1-26.72.3.i386.rpm
2.
3.
	

Actual Results:  error: failed dependencies:
        perl-CPAN is needed by perl-5.6.1-26.72.3
        perl-CGI is needed by perl-5.6.1-26.72.3
        perl-DB_File is needed by perl-5.6.1-26.72.3
        perl-NDBM_File is needed by perl-5.6.1-26.72.3

Expected Results:  The RPM should isntall fine.

Additional info:

Like I said above, if you're going to seperate out the way a package works, save
it for the next rev of the OS.  The way you've done this package makes it more
difficult to do a simple rpm -Fvh on a directory containing the latest Errata.

Simply, the errata package should have the SAME depedencies as the original
package, and definately NOT more.
Comment 1 Chip Turner 2002-03-06 18:40:40 EST
This is caused because the CPAN, CGI, DB_File, and NDBM_File perl modules were
broken out into separate RPM packages.  The old perl, 5.6.0, included them all,
just as the new one does.  They are separated for easier errataing of only those
packages (CGI.pm and CPAN.pm being two of the more commonly updated CPAN modules).

If the requirement weren't there, you would be able to -Fvh perl and suddenly
not have a CGI.pm or DB_File module.

So the result is the same functionality, and same perl modules, but in different
separate RPM packages.  No new software is being required, it's just put into
diffent RPMs.
Comment 2 Need Real Name 2002-03-07 09:11:47 EST
How can you say no software is required and when I try to Fvh the perl errata it
tells me :

Actual Results:  error: failed dependencies:
        perl-CPAN is needed by perl-5.6.1-26.72.3
        perl-CGI is needed by perl-5.6.1-26.72.3
        perl-DB_File is needed by perl-5.6.1-26.72.3
        perl-NDBM_File is needed by perl-5.6.1-26.72.3

These are not RPMS that were required with the original Perl RPM, therefore they
are required with the errata RPM.  Obviously additional software is required.  I
understand why you did it, and it's all fine and dandy, except for the fact that
it breaks they way that RPM upgrades should work.  

Clearly something else is wrong here as well.. Even when I try to install the
Errata with an -ivh, it returns:

[root@quickblade-01]# rpm -ivh perl-CGI-2.752-26.72.3.i386.rpm
error: failed dependencies:
        perl >= 1:5.6.1-26.72.3 is needed by perl-CGI-2.752-26.72.3
[root@quickblade-01]# rpm -ivh perl-CPAN-1.59_54-26.72.3.i386.rpm
error: failed dependencies:
        perl >= 1:5.6.1-26.72.3 is needed by perl-CPAN-1.59_54-26.72.3
[root@quickblade-01]# rpm -ivh perl-DB_File-1.75-26.72.3.i386.rpm
error: failed dependencies:
        perl >= 1:5.6.1-26.72.3 is needed by perl-DB_File-1.75-26.72.3
[root@quickblade-01]# rpm -ivh perl-NDBM_File-1.75-26.72.3.i386.rpm
error: failed dependencies:
        perl >= 1:5.6.1-26.72.3 is needed by perl-NDBM_File-1.75-26.72.3
[root@quickblade-01]# rpm -ivh perl-5.6.1-26.72.3.i386.rpm
error: failed dependencies:
        perl-CPAN is needed by perl-5.6.1-26.72.3
        perl-CGI is needed by perl-5.6.1-26.72.3
        perl-DB_File is needed by perl-5.6.1-26.72.3
        perl-NDBM_File is needed by perl-5.6.1-26.72.3


It seems impossible to install any of those packages, because they are all
dependent on each other.  

The instructions state on 

http://www.redhat.com/support/errata/RHBA-2002-023.html 

"To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]"

If these Errata aren't working as documented there, then there is a bug.


Comment 3 Chip Turner 2002-03-07 09:51:04 EST
It's not "new" software; it's software you had before, just packaged in a
different way.  It's a subtle difference, but in this case it is simply moving
the same Perl modules into different RPM packages.  In particular, the new
packaging doesn't let someone mistakenly only upgrade perl and suddenly be
missing CGI, CPAN, DB_File, and NDBM_File.

However, you can, indeed, do the upgrade.  The correct procedure is to "rpm -Uvh
[filenames]" where [filenames] is all five new Perl packages (or six if you want
to upgrade mod_perl).  The text of the errata will be updated to reflect the
incorrect instructions.
Comment 4 Leonard den Ottolander 2004-04-22 12:03:01 EDT
rpm -Uv perl* should have done the trick.

This is behaviour the reporter doesn't like, but not really a bug.

Note You need to log in before you can comment on or make changes to this bug.