Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608157 - Unable to update to latest perl because of dependency problems.
Unable to update to latest perl because of dependency problems.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 16:33 EDT by Gene Snider
Modified: 2010-07-01 14:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 10:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Snider 2010-06-25 16:33:03 EDT
Description of problem: The available perl update can't be installed do to dependency problems.

Version-Release number of selected component (if applicable):
perl.x86_64 4:5.12.1-123.fc14

How reproducible:
Easily.

Steps to Reproduce:
1. Run "sudo yum update"
2.
3.
  
Actual results:
--> Finished Dependency Resolution
Error: Package: 1:net-snmp-libs-5.5-15.fc14.x86_64 (@rawhide)
           Requires: perl(:MODULE_COMPAT_5.10.1)
           Removing: 4:perl-5.10.1-118.fc14.x86_64 (@rawhide)
               perl(:MODULE_COMPAT_5.10.1)
           Updated By: 4:perl-5.12.1-123.fc14.x86_64 (rawhide)
               Not found
Error: Package: perl-Git-1.7.1-1.fc14.noarch (@rawhide)
           Requires: perl(:MODULE_COMPAT_5.10.1)
           Removing: 4:perl-5.10.1-118.fc14.x86_64 (@rawhide)
               perl(:MODULE_COMPAT_5.10.1)
           Updated By: 4:perl-5.12.1-123.fc14.x86_64 (rawhide)
               Not found

Expected results:
Successful update.

Additional info:
This bug should probably be filed against net-snmp-libs and perl-Git, but I couldn't find perl-Git in the component list even though it shows up in "yum list perl-git".  Could you let the responsible parties know that their packages need to be rebuilt against the new perl, please?

Thanks,
Gene
Comment 1 Marcela Mašláňová 2010-07-01 10:05:43 EDT
Hello,
both packages were already rebuilt. This should be fine now. Feel free to reopen this bug if anything was wrong.
Comment 2 Gene Snider 2010-07-01 14:51:53 EDT
All is well, thanks!

Gene

Note You need to log in before you can comment on or make changes to this bug.