Bug 608346 - Lenovo W510: display doesn't come up after resume
Lenovo W510: display doesn't come up after resume
Status: CLOSED DUPLICATE of bug 480311
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pm-utils (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-26 18:12 EDT by David Kovalsky
Modified: 2014-03-31 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 11:09:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (80.56 KB, text/plain)
2010-06-26 18:12 EDT, David Kovalsky
no flags Details
/var/log/pm/suspend.log (23.70 KB, text/plain)
2010-06-26 18:14 EDT, David Kovalsky
no flags Details
lsmod (6.07 KB, text/plain)
2010-08-12 10:46 EDT, David Kovalsky
no flags Details
lshal (142.19 KB, text/plain)
2010-12-15 11:40 EST, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2010-06-26 18:12:26 EDT
pm-utils-0.99.3-10.el5

Notebook properly suspends, but after resume the display is just blank (dark, doesn't come up). Given that NetworkManager connects to the network and I can ssh onto the machine, I expect everything else is fine.
Comment 1 David Kovalsky 2010-06-26 18:12:56 EDT
Created attachment 427150 [details]
/var/log/messages
Comment 2 David Kovalsky 2010-06-26 18:14:07 EDT
Created attachment 427151 [details]
/var/log/pm/suspend.log
Comment 3 David Kovalsky 2010-06-26 18:20:48 EDT
FYI - hibernate works flawlessly.
Comment 4 Jaroslav Škarvada 2010-07-16 15:26:22 EDT
Looks like problem with vbetool/video BIOS. Could you provide output of lsmod? Please also try with various video quirks, the list of quirks is available from /usr/lib/pm-utils/bin/pm-action --help
Comment 6 RHEL Product and Program Management 2010-08-09 14:44:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 David Kovalsky 2010-08-12 10:46:07 EDT
Created attachment 438458 [details]
lsmod
Comment 8 David Kovalsky 2010-08-12 11:01:59 EDT
Sorry for the late response. 

Quirks:
 -dpms-on -> no change
 -dpms-suspend -> no change
 -radeon-off / s3-bios / s3-mode -> haven't tried (does it apply to nVidia?)
 -vbe-post -> half success! External monitor came up, notebook display is still "dead". But better then nothing :)
Comment 9 David Kovalsky 2010-08-12 11:22:53 EDT
also tried   -vbemode-restore/vbestate-restore/vga-mode3 -> no change.
Comment 10 Jaroslav Škarvada 2010-08-16 04:19:36 EDT
Does VT switch (ALT + [CTRL] + NUMs) help? Or is the display completely dead?
Comment 11 David Kovalsky 2010-08-16 05:05:59 EDT
Completely dead, dead black.
Comment 12 Jaroslav Škarvada 2010-12-15 10:39:48 EST
Thanks for info, please provide sosreport and output of lshal.
Comment 13 David Kovalsky 2010-12-15 11:40:31 EST
Created attachment 468887 [details]
lshal

lshal attached. 

Booted to runlevel 5, CTRL+ALT+F1, login as root. lshal > $log. 

I've XXXX-ed out a couple of the serial numbers. In the unlikely case they are needed and should make a difference please let me know.
Comment 15 Jaroslav Škarvada 2010-12-16 11:09:26 EST

*** This bug has been marked as a duplicate of bug 480311 ***

Note You need to log in before you can comment on or make changes to this bug.