Bug 608346 - Lenovo W510: display doesn't come up after resume
Summary: Lenovo W510: display doesn't come up after resume
Status: CLOSED DUPLICATE of bug 480311
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pm-utils   
(Show other bugs)
Version: 5.5
Hardware: All Linux
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: desktop-bugs@redhat.com
Depends On:
TreeView+ depends on / blocked
Reported: 2010-06-26 22:12 UTC by David Kovalsky
Modified: 2014-03-31 23:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-16 16:09:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/messages (80.56 KB, text/plain)
2010-06-26 22:12 UTC, David Kovalsky
no flags Details
/var/log/pm/suspend.log (23.70 KB, text/plain)
2010-06-26 22:14 UTC, David Kovalsky
no flags Details
lsmod (6.07 KB, text/plain)
2010-08-12 14:46 UTC, David Kovalsky
no flags Details
lshal (142.19 KB, text/plain)
2010-12-15 16:40 UTC, David Kovalsky
no flags Details

Description David Kovalsky 2010-06-26 22:12:26 UTC

Notebook properly suspends, but after resume the display is just blank (dark, doesn't come up). Given that NetworkManager connects to the network and I can ssh onto the machine, I expect everything else is fine.

Comment 1 David Kovalsky 2010-06-26 22:12:56 UTC
Created attachment 427150 [details]

Comment 2 David Kovalsky 2010-06-26 22:14:07 UTC
Created attachment 427151 [details]

Comment 3 David Kovalsky 2010-06-26 22:20:48 UTC
FYI - hibernate works flawlessly.

Comment 4 Jaroslav Škarvada 2010-07-16 19:26:22 UTC
Looks like problem with vbetool/video BIOS. Could you provide output of lsmod? Please also try with various video quirks, the list of quirks is available from /usr/lib/pm-utils/bin/pm-action --help

Comment 6 RHEL Product and Program Management 2010-08-09 18:44:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 7 David Kovalsky 2010-08-12 14:46:07 UTC
Created attachment 438458 [details]

Comment 8 David Kovalsky 2010-08-12 15:01:59 UTC
Sorry for the late response. 

 -dpms-on -> no change
 -dpms-suspend -> no change
 -radeon-off / s3-bios / s3-mode -> haven't tried (does it apply to nVidia?)
 -vbe-post -> half success! External monitor came up, notebook display is still "dead". But better then nothing :)

Comment 9 David Kovalsky 2010-08-12 15:22:53 UTC
also tried   -vbemode-restore/vbestate-restore/vga-mode3 -> no change.

Comment 10 Jaroslav Škarvada 2010-08-16 08:19:36 UTC
Does VT switch (ALT + [CTRL] + NUMs) help? Or is the display completely dead?

Comment 11 David Kovalsky 2010-08-16 09:05:59 UTC
Completely dead, dead black.

Comment 12 Jaroslav Škarvada 2010-12-15 15:39:48 UTC
Thanks for info, please provide sosreport and output of lshal.

Comment 13 David Kovalsky 2010-12-15 16:40:31 UTC
Created attachment 468887 [details]

lshal attached. 

Booted to runlevel 5, CTRL+ALT+F1, login as root. lshal > $log. 

I've XXXX-ed out a couple of the serial numbers. In the unlikely case they are needed and should make a difference please let me know.

Comment 15 Jaroslav Škarvada 2010-12-16 16:09:26 UTC

*** This bug has been marked as a duplicate of bug 480311 ***

Note You need to log in before you can comment on or make changes to this bug.