Bug 608374 - wget encoding issue displays â instead of apostrophe.
Summary: wget encoding issue displays â instead of apostrophe.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: wget   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 01:36 UTC by supaphat21
Modified: 2010-07-12 13:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 13:11:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description supaphat21 2010-06-27 01:36:54 UTC
Description of problem:
wget does not appear to properly encode apostrophe characters.

Version-Release number of selected component (if applicable):
wget-1.12-1.2.el6.x86_64

How reproducible:


Steps to Reproduce:
1. download a file with wget
2. search the man wget for the phrase "donât"
3. type wget -V and notice other characters not being encoded properly
  
Actual results:
File download output:

Saving to: âfile.tgz.1â

100%[==========================================================================================>] 112,517      292K/s   in 0.4s

2010-06-26 21:27:57 (292 KB/s) - âfile.tgz.1â




Expected results:
Saving to: `file.tgz.1'

100%[==========================================================================================>] 112,517      292K/s   in 0.4s

2010-06-26 21:27:57 (292 KB/s) - `file.tgz.1'


Additional info:

Comment 1 supaphat21 2010-06-27 01:43:22 UTC
This could be unrelated to wget but more towards the locale I am using en_US.UTF-8 however this is the first I have noticed this issue.

Comment 3 RHEL Product and Program Management 2010-06-27 02:02:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Karsten Hopp 2010-07-08 11:28:44 UTC
which terminal are you using ? konsole, xterm, gnome-terminal ? Or is this without X on the console ?

Comment 6 supaphat21 2010-07-12 00:45:15 UTC
After looking more closely at the situation the issue isn't exactly an issue with wget. However, the behavior is different then other linux/unix distros. This may be WAD, but here is what I have found for comparison.

echo $TERM == xterm

1. ubuntu via local or putty:

Saving to: `file.tgz'

2. solaris via openssh or putty:

Saving to: `file.tgz'

2. rhel6 via openssh:

Saving to: “file.tgz”

3. rhel6 via putty:

Saving to: âfile.tgzâ


So it appears as though putty doesn't understand the ” marks.

Comment 7 Karsten Hopp 2010-07-12 07:34:57 UTC
Please check putty's options and make sure that the character encoding is set to UTF-8. It might be that putty defaults to ISO-8859-1 or something similar.

Comment 8 supaphat21 2010-07-12 12:48:00 UTC
Changing it to UTF-8 forces the quotation to be properly displayed. The default was ISO-8859-1. Thanks for the assistance.


Note You need to log in before you can comment on or make changes to this bug.