Bug 60841 - API: System Notes
Summary: API: System Notes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: RHN Devel
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: Fanny Augustin
URL: http://webapp.rwc-colo.redhat.com/net...
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 106570
TreeView+ depends on / blocked
 
Reported: 2002-03-07 20:30 UTC by Greg DeKoenigsberg
Modified: 2007-04-18 16:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 19:49:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg DeKoenigsberg 2002-03-07 20:30:16 UTC
We need to expose an XMLRPC method to system notes -- it's an ideal place for a
customer to store arbitrary tuples that might be terribly important to them, but
useless to us.

Comment 1 Greg DeKoenigsberg 2002-03-07 20:32:03 UTC
Adding Isaiah to the CC: list

Comment 2 Greg DeKoenigsberg 2002-03-21 16:12:36 UTC
I believe that Chip has a version of this functioning on the dev servers.  Chip,
is this suitable for push?  Do we need to clean it up?

Comment 3 Chip Turner 2002-03-21 19:38:59 UTC
Yes, the capability for this now exists on the servers.  We also have a script
that ties into it, though it hasn't been made publicly available.

Comment 4 Josef Komenda 2003-08-28 16:15:12 UTC
Could this be part of the new API we're developing? 

Comment 5 Chip Turner 2003-09-11 14:31:53 UTC
indeed; it is now in the web api and is tested via test scripts.  will remain
private until we expose the API as a whole but it is in and formalized

Comment 6 Josef Komenda 2003-09-18 14:09:14 UTC
Test plan please. 

Comment 7 Chip Turner 2003-09-23 12:52:50 UTC
there are automated tests for this feature in place.  beyond that what is the
test plan?

Comment 8 Josef Komenda 2003-09-23 13:18:46 UTC
So - no testing required by QA? gdk?

Comment 9 Greg DeKoenigsberg 2003-09-26 14:34:31 UTC
Deferring to rhn290.

Comment 10 Greg DeKoenigsberg 2003-10-09 00:21:34 UTC
Moving under api290.

Comment 11 Chip Turner 2003-11-06 21:07:11 UTC
this has been in for a long time; the issue is test plan.  for now,
there's no qa that can be done without qa folks writing scripts, so
there is no testing that can really be done right now

Comment 12 Matt Jamison 2004-01-29 19:49:24 UTC
closing.


Note You need to log in before you can comment on or make changes to this bug.