Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608412 - hp: prnt/backend/hp.c 847: ERROR: null print job total=0
hp: prnt/backend/hp.c 847: ERROR: null print job total=0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-27 08:32 EDT by Damian Wrobel
Modified: 2010-09-02 04:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 04:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tail -n 100 /var/log/cups/error_log (15.58 KB, text/plain)
2010-06-28 14:34 EDT, Damian Wrobel
no flags Details

  None (edit)
Description Damian Wrobel 2010-06-27 08:32:43 EDT
Description of problem:
Printing doesn't work from any program (lp, acrobat, etc) (printer DESKJET-930C). There is only the following error in the /var/log/messages file:
hp[17324]: prnt/backend/hp.c 847: ERROR: null print job total=0


Version-Release number of selected component (if applicable):
It's happens on fully updated fc12 even if I updated hp\* and cups\* packages
from the testing-updates.

#rpm -qa | grep -e ^hp -e ^cups
cups-devel-1.4.4-4.fc12.i686
hplip-libs-3.10.5-1.fc12.i686
hplip-gui-3.10.5-1.fc12.i686
hplip-common-3.10.5-1.fc12.i686
cups-pdf-2.5.0-3.fc12.i686
hpijs-3.10.5-1.fc12.i686
cups-libs-1.4.4-4.fc12.i686
hplip-3.10.5-1.fc12.i686
cups-1.4.4-4.fc12.i686


How reproducible:
100%, at least for me.


Steps to Reproduce:
1. Try to print something using either lp or any other program e.g. acrobat
  
Actual results:
lpq
DESKJET-930C is ready and printing
Rank    Owner   Job     File(s)                         Total Size
1st     dw      741     A9ROfoZs5T                      322560 bytes

/var/log/messages:
hp[17324]: prnt/backend/hp.c 847: ERROR: null print job total=0

Expected results:
Document should be printed.

Additional info:
I don't know precisely when it stopped work (after which update).
Comment 1 Jiri Popelka 2010-06-28 09:50:26 EDT
Can you attach output from Printing troubleshooter ?
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
thanks
Comment 2 Damian Wrobel 2010-06-28 14:34:31 EDT
Created attachment 427479 [details]
tail -n 100 /var/log/cups/error_log
Comment 3 Damian Wrobel 2010-06-28 14:42:57 EDT
(In reply to comment #1)
> Can you attach output from Printing troubleshooter ?
Unfortunately, the program getting stuck and is not able to collect the troubleshoot.txt file.
Comment 4 Tim Waugh 2010-06-30 07:33:53 EDT
Hmm, the weird "con->data_remaining=-2364888507" thing looks like a cups bug.  But the original problem here is the hp "null print job" problem.

Are you able to follow the "Getting debug information by other means" part of that wiki page to get a complete error_log file?  Hopefully that cups bug won't trigger this way.
Comment 5 Damian Wrobel 2010-07-02 14:42:57 EDT
(In reply to comment #4)
The log (attachment #427479 [details]) was taken once I set LogLevel=debug2 and restarted the cups service.
Comment 6 Tim Waugh 2010-09-01 07:10:05 EDT
Could you try again please?  The file has been wrapped around due to being too large.
Comment 7 Damian Wrobel 2010-09-01 14:39:47 EDT
(In reply to comment #6)
In the meantime I've upgraded this machine to F-13 and I didn't notice similar problem so far.
Comment 8 Tim Waugh 2010-09-02 04:34:57 EDT
OK, closing.  Sorry it took so long to get to this.

Note You need to log in before you can comment on or make changes to this bug.