Bug 608422 - gnome-appearance-properties crash on Fedora 14 rawhide
Summary: gnome-appearance-properties crash on Fedora 14 rawhide
Status: CLOSED DUPLICATE of bug 613438
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-27 13:24 UTC by Athmane Madjoudj
Modified: 2010-07-22 13:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 13:37:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (35.74 KB, application/octet-stream)
2010-06-27 13:30 UTC, Athmane Madjoudj
no flags Details

Description Athmane Madjoudj 2010-06-27 13:24:43 UTC
Description of problem:


Version-Release number of selected component (if applicable):
control-center-2.31.3-2.fc14.i686
gtk2-2.21.2-2.fc14.i686
gtk3-2.90.3-1.fc14.i686

How reproducible:
Always

Steps to Reproduce:
1. Run gnome-appearance-properties
2.
3.
  
Actual results:
gnome-appearance-properties crash.

Expected results:
gnome-appearance-properties doesn't crash.

Additional info:
 gnome-appearance-properties 

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)

Comment 1 Athmane Madjoudj 2010-06-27 13:30:47 UTC
Created attachment 427204 [details]
strace output

Strace-ing doesn't finish, and CPU is 100%.

Comment 2 Jan Dvořák 2010-07-02 05:48:29 UTC
It itself only loads GTK+ 3:

readelf -d /usr/bin/gnome-appearance-properties|grep gtk
 0x0000000000000001 (NEEDED)             Shared library: [libgtk-x11-3.0.so.0]

But it's dependency libmetacity-private.so.0 pulls in GTK+ 2.x:

readelf -d /usr/lib64/libmetacity-private.so.0 | grep gtk
 0x0000000000000001 (NEEDED)             Shared library: [libcanberra-gtk.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libgtk-x11-2.0.so.0]

Comment 3 Bastien Nocera 2010-07-22 13:37:33 UTC

*** This bug has been marked as a duplicate of bug 613438 ***


Note You need to log in before you can comment on or make changes to this bug.