Bug 608600 - Firefox doesn't open after upgrade
Firefox doesn't open after upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 05:20 EDT by Mikael Karlsson
Modified: 2010-06-29 03:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 03:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of firefox (17.95 KB, text/plain)
2010-06-28 15:20 EDT, Mikael Karlsson
no flags Details

  None (edit)
Description Mikael Karlsson 2010-06-28 05:20:48 EDT
Description of problem:
Firefox doesn't start after upgrade to lastest version from updates. 

[mikael@fedora ~]$ rpm -qa firefox
firefox-3.6.4-1.fc13.i686


Firefox seems to be running then checking
[mikael@fedora ~]$ ps aux | grep -i firefox
mikael   30175  0.0  0.0   5048  1228 ?        S    10:58   0:00 /bin/sh /usr/lib/firefox-3.6/run-mozilla.sh /usr/lib/firefox-3.6/firefox https://bugzilla.redhat.com/token.cgi?t=miI9wv8CYW&a=request_new_account
mikael   30193  0.0  0.6 258484 42812 ?        Sl   10:58   0:00 /usr/lib/firefox-3.6/firefox https://bugzilla.redhat.com/token.cgi?t=miI9wv8CYW&a=request_new_account
mikael   30427  0.0  0.0   5048  1192 pts/1    S+   11:15   0:00 /bin/sh /usr/bin/firefox
mikael   30433  0.0  0.0   5968  1220 pts/1    S+   11:15   0:00 /usr/lib//xulrunner-1.9.2/mozilla-xremote-client -a firefox ping()


I have tried to start in safemode and that doesn't work either. 

This system is upgraded from FC12 to FC13 

I also got the libedataserver-1.2.so.11 problem on this system. 


Version-Release number of selected component (if applicable):
firefox-3.6.4-1.fc13.i686

How reproducible:
Always happens

Steps to Reproduce:
1. Always happens
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mikael Karlsson 2010-06-28 15:20:18 EDT
Created attachment 427486 [details]
Strace of firefox
Comment 2 Martin Stransky 2010-06-29 00:57:41 EDT
Can you try to start it inside gdb (firefox -g -d gdb and then "r")? Or create and start it with new profile (firefox -ProfileManager)?
Comment 3 Mikael Karlsson 2010-06-29 01:22:42 EDT
[mikael@fedora ~]$ firefox -g -d gdb
MOZILLA_FIVE_HOME=/usr/lib/firefox-3.6
  LD_LIBRARY_PATH=/usr/lib/firefox-3.6:/usr/lib/firefox-3.6/plugins:/usr/lib/firefox-3.6
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/firefox-3.6/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/firefox-3.6:/usr/lib/firefox-3.6
     LIBRARY_PATH=/usr/lib/firefox-3.6:/usr/lib/firefox-3.6/components:/usr/lib/firefox-3.6
       SHLIB_PATH=/usr/lib/firefox-3.6:/usr/lib/firefox-3.6
          LIBPATH=/usr/lib/firefox-3.6:/usr/lib/firefox-3.6
       ADDON_PATH=/usr/lib/firefox-3.6
      MOZ_PROGRAM=/usr/lib/firefox-3.6/firefox
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=gdb
/usr/bin/gdb /usr/lib/firefox-3.6/firefox -x /tmp/mozargs.Z1Ck8J
GNU gdb (GDB) Fedora (7.1-26.fc13)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/firefox-3.6/firefox...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install firefox-3.6.4-1.fc13.i686
(gdb) r
Starting program: /usr/lib/firefox-3.6/firefox 
[Thread debugging using libthread_db enabled]
[New Thread 0xb7affb70 (LWP 16841)]
[New Thread 0xb6effb70 (LWP 16842)]
[New Thread 0xb64feb70 (LWP 16843)]
[New Thread 0xb5afdb70 (LWP 16844)]
[New Thread 0xb4dffb70 (LWP 16845)]
[New Thread 0xb3effb70 (LWP 16846)]
[New Thread 0xae8ffb70 (LWP 16847)]
[New Thread 0xadbffb70 (LWP 16848)]
[New Thread 0xacfffb70 (LWP 16849)]
[Thread 0xacfffb70 (LWP 16849) exited]
Detaching after fork from child process 16850.
Detaching after fork from child process 16852.
[New Thread 0xacfffb70 (LWP 16854)]
[New Thread 0xac3ffb70 (LWP 16855)]
[New Thread 0xab9feb70 (LWP 16856)]
..................


And it worked creating a new profile....
Comment 4 Martin Stransky 2010-06-29 03:09:37 EDT
Well it's something wrong with your profile then...

Note You need to log in before you can comment on or make changes to this bug.