Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608617 - gpgsm missing from GnuPG and causing problems when installing local rpm files
gpgsm missing from GnuPG and causing problems when installing local rpm files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnupg2 (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 06:13 EDT by Dae Won
Modified: 2010-06-29 16:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 06:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dae Won 2010-06-28 06:13:18 EDT
Description of problem: On Fedora 13 i am not able to install local rpm files and i get an error that
it is an untrusted package and it ACTS like it installed but did not. So
Kleopatra told me that gpgsm was not installed properly. It was not installed
at all. So i checked the file list in the Fedora 13 repo for GnuPG and it was
not included.


Version-Release number of selected component (if applicable): GnuPG2


How reproducible: Always


Steps to Reproduce:
1.Attempt to install local rpm files
2.
3.
  
Actual results:says an untrusted package has been installed. But it does not really get installed. It will install if you install through terminal with --nogpgcheck


Expected results:to install with kpackagkit as it is supposed to


Additional info:
Comment 1 Tomas Mraz 2010-06-28 06:27:45 EDT
This is mix-up of a few misunderstandings and not a bug.

1. The gpgsm is not missing, you have to install the gnupg2-smime package to have it.

2. The gpgsm is not needed for the rpm gpg signature checks.

3. The local rpms are probably not signed or (in case you signed them) the public key is not imported to the local database, that's why they have to be installed with --nogpgcheck. Whether gpgsm is installed or not does not matter in this case.
Comment 2 Dae Won 2010-06-28 06:54:05 EDT
One rpm was for the opera browser and two were from google. if it's not the missing file where would i begin looking into this issue at?
Comment 3 Tomas Mraz 2010-06-28 07:04:35 EDT
You need to find the public keys and import them into the RPM database.
Comment 4 Tomas Mraz 2010-06-28 07:05:28 EDT
The public keys should be provided by the sites that provide the RPMs you want to install. Sometimes they are provided in the form of repository package.
Comment 5 Adam Williamson 2010-06-29 16:52:49 EDT
i think hidden in here somewhere is an RFE for kpackagekit to allow the installation of unsigned packages, or at least that's more how it's phrased in the associated forum thread: http://forums.fedoraforum.org/showthread.php?p=1376262 .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.