Bug 608671 - Missing feature: Ability to paste host clipboard as keyboard input into VM
Summary: Missing feature: Ability to paste host clipboard as keyboard input into VM
Status: CLOSED WONTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager   
(Show other bugs)
Version: unspecified
Hardware: All All
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-28 12:51 UTC by Коренберг Марк
Modified: 2012-01-17 22:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-17 22:23:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Коренберг Марк 2010-06-28 12:51:10 UTC
Missing feature: Ability to paste host clipboard as keyboard input into VM

The different task is clipboard communication between host and guest VM. This task does not mean that :).

This feature exists in Micorsoft VirtualPC (Hyper-V)
but buggy - only limited amount of text may be copied.
Also, timeouts while pressing/unpressing keys, timeout between buttons should be like real - so generic programs should not recognize such hack :)

I need that for typing "wget $URL" where URL is copied from browser.

Comment 1 Cole Robinson 2012-01-17 22:23:05 UTC
Thanks for the report. However since spice has arrived and can give us actual copy paste with some guest cooperation, it's unlikely that this will ever be generically implemented in virt-manager, especially given the difficulties of the problem that you report.

Closing as WONTFIX


Note You need to log in before you can comment on or make changes to this bug.