Bug 60871 - gcc crash when compiling gpgme (http://www.gnupg.org/gpgme.html)
Summary: gcc crash when compiling gpgme (http://www.gnupg.org/gpgme.html)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-08 02:26 UTC by LeAg
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:29:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.i : output of gcc with -save-temps option (76.49 KB, text/plain)
2002-03-11 10:06 UTC, LeAg
no flags Details

Description LeAg 2002-03-08 02:26:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
gcc crash when compiling engine.c of gpgme-0.3.4 project 
(http://www.gnupg.org/gpgme.html)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. untar gpgme-0.3.4.tar.gz
2. cd gpgme-0.3.4
3. ./configure 
4. make 
5. wait & see the crash
	

Actual Results:  gcc returns :
engine.c: In function `_gpgme_engine_new':
engine.c:194: internal error: Erreur de segmentation
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  engine.o !!

Additional info:

duron 850/ 128 MB ram

# rpm -qa | egrep "glibc|make|gcc"
gcc-3.1-0.17
glibc-common-2.2.4-19.3
make-3.79.1-5
libgcc-3.1-0.17
automake-1.5-8
glibc-devel-2.2.4-19.3
pmake-1.45-1
gcc-c++-3.1-0.17
glibc-2.2.4-19.3

Comment 1 Jakub Jelinek 2002-03-09 21:47:17 UTC
If it is reproduceable, please mention here full gcc command line used to compile
engine.c, rerun gcc with additional -save-temps option and attach here
engine.i.

Comment 2 LeAg 2002-03-11 10:06:11 UTC
Created attachment 48092 [details]
engine.i : output of gcc with -save-temps option

Comment 3 LeAg 2002-03-11 10:08:08 UTC
the command line used to compile engine.i : 
gcc -O9 -funroll-loops -ffast-math -malign-double -mcpu=pentiumpro
-march=pentiumpro -fomit-frame-pointer -fno-exceptions -Wall -Wcast-align
-Wshadow -Wstrict-prototypes -save-temps    engine.c   -o engine

the error message : 
In file included from util.h:25,
                 from engine.c:31:
types.h:31: warning: redefinition of `ulong'
/usr/include/sys/types.h:150: warning: `ulong' previously declared here
engine.c: In function `_gpgme_engine_new':
engine.c:194: internal error: Erreur de segmentation


Comment 4 Jakub Jelinek 2002-03-11 10:56:43 UTC
Cannot reproduce this with any of gcc-3.1-0.14, gcc-3.1-0.18, gcc-3.1-0.21,
gcc-3.1-0.22 nor gcc-2.96-105.


Note You need to log in before you can comment on or make changes to this bug.