Bug 608816 - sssd + ldap: acroread in trouble
sssd + ldap: acroread in trouble
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 13:43 EDT by Terje Røsten
Modified: 2010-06-28 14:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 14:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Røsten 2010-06-28 13:43:30 EDT
Description of problem:

acroread have some kind of feature/bug that means that nscd needs
to be running for acroread to work when auth/user info are in LDAP
(using nss_ldap and friends). See e.g. 

http://allaboutfedora.blogspot.com/2009/02/f10-how-to-fix-getpwuidr-failure.html

(or google for 
 GLib-WARNING **: getpwuid_r(): failed due to unknown user id acroread)

Now with sssd it's "forbidden" to run nscd and guess what? 
acroread don't work...

Is it really impossible to run nscd with sssd? 

Any idea of a more clever solution?

Version-Release number of selected component (if applicable):

sssd-1.2.0-12.fc13.x86_64
Comment 1 Terje Røsten 2010-06-28 13:53:02 EDT
Ok guys, I found https://fedorahosted.org/sssd/ticket/190 and indeed, installing
sssd-client.i686 fix the problem.

However, again, I can't find the need for 32 bits sssd-client on 64 bits install documented in the sssd man pages.
Comment 2 Stephen Gallagher 2010-06-28 14:02:11 EDT
I'm not sure where in the man pages it would be appropriate to mention it. Please feel free to suggest the documentation you would like to see. This doesn't really belong in SSSD's manpages, as it's a distribution issue. Probably this should be added to http://fedoraproject.org/wiki/Common_F13_bugs. Please feel free to add it.

The 32-bit sssd-client is only required for 32-bit applications to talk to SSSD. This usually means third-party applications, as nearly every application in Fedora proper is compiled natively for 64-bit (when using x86_64).

Note You need to log in before you can comment on or make changes to this bug.