Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608911 - Libwimp fix available
Libwimp fix available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw32-gtk2 (Show other bugs)
13
i686 Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 17:43 EDT by Andrea Santilli
Modified: 2010-07-27 17:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: mingw32-gtk2-2.20.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 22:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2010-06-28 17:43:03 EDT
Description of problem:
Libwimp has been broken since version 2.18.0 (bug report here: https://bugzilla.gnome.org/show_bug.cgi?id=598299) so since then GTK+ applications have been unable to look 'native' on Windows.

It looks like the last patches submitted to that report fix the problem fine and have already been submitted to trunk, probably for version 2.22.0.

I've been testing them (both gtk+-2.20.1-xptheme-v16.patch and gtk+-2.20.1-gdkwin32-offscreen-v3.patch together) and they seem to work fine on Vista original and Wine with a native XP theme.

Please take in consideration the chance to use those patches, as the fix would be useful for people packaging win32 applications together with a GTK+ runtime.

Version-Release number of selected component (if applicable):
2.19.6
Comment 1 Fedora Update System 2010-07-04 12:10:39 EDT
mingw32-gtk2-2.20.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mingw32-gtk2-2.20.1-2.fc13
Comment 2 Fedora Update System 2010-07-06 13:25:14 EDT
mingw32-gtk2-2.20.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mingw32-gtk2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mingw32-gtk2-2.20.1-2.fc13
Comment 3 Fedora Update System 2010-07-26 22:28:25 EDT
mingw32-gtk2-2.20.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Andrea Santilli 2010-07-27 17:26:44 EDT
Sorry, I haven't had the time to check that update for a while. Anyway version 2.20.1-2 works just fine for me, thank you very much :)

Note You need to log in before you can comment on or make changes to this bug.