Bug 60896 - named exits after resume on laptop
named exits after resume on laptop
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 11:18 EST by Joe Harrington
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 11:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 2002-03-08 11:18:06 EST
Description of Problem:

named exits with the following error after most long suspends:

Mar  6 11:15:44 glup named[749]: ifiter_ioctl.c:214: REQUIRE(iter->pos <
(unsigned int) iter->ifc.ifc_len) failed
Mar  6 11:15:44 glup named[749]: exiting (due to assertion failure)

Version-Release number of selected component (if applicable):

bind-9.1.3-4

How Reproducible:

Pretty much.  I get the error most mornings on my laptop after it has been
suspended all night.

Steps to Reproduce:
1. start named
2. apm -s
3. ssh brain -l root sleep 28800
5. start laptop
6. attempt to resolve a name
7. find error in syslog after resolution failure

Actual Results:
Named not running, error above, no name service (using cacheing server).

Expected Results:
name service, named running, peace in Afghanistan

Additional Information:
From /var/log/messages:

Mar  5 14:59:52 glup apmd[618]: Charge: -0.126891 (1:42) 0:00 (100% 7:26)
Mar  5 20:12:56 glup apmd[618]: User Suspend
Mar  6 11:15:44 glup apmd[618]: Charge: 0.001517 (21:58) 4294967290 days,
4294967276:4294967250 (85% unknown)
Mar  6 11:15:44 glup named[749]: ifiter_ioctl.c:214: REQUIRE(iter->pos <
(unsigned int) iter->ifc.ifc_len) failed
Mar  6 11:15:44 glup named[749]: exiting (due to assertion failure)
Mar  6 11:15:57 glup apmd[618]: Normal Resume after 15:03:01 (85% unknown) AC power
Mar  6 11:16:00 glup apmd[618]: Normal Resume after 15:03:04 (85% 3:54) AC
powerMar  6 12:16:49 glup apmd[618]: Charge: -0.164429 (1:01) 0:30 (95% 6:42)
Mar  6 12:21:16 glup apmd[618]: Battery: -0.229826 (1:05) 4294967289:4294967282
(100% 7:35)

The named error is identical each time, and happens right with the resume when
it happens.

--jh--
Comment 1 Bernhard Rosenkraenzer 2002-03-11 10:23:09 EST
named doesn't like having network interfaces pulled away under its feet. 
 
The current apmd package has some workarounds ("RESTARTSERVICES") for this. 

Note You need to log in before you can comment on or make changes to this bug.