Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 609037 - RFE: WDM option missing in sysconfig.txt documentation
RFE: WDM option missing in sysconfig.txt documentation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 05:12 EDT by Jaroslav Reznik
Modified: 2014-03-16 23:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 20:03:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2010-06-29 05:12:28 EDT
Description of problem: WDM option missing in sysconfig.txt documentation

Steps to Reproduce:
1. cat /usr/share/doc/initscripts-9.12/sysconfig.txt | grep DISPLAYMANAGER
  
Actual results:
DISPLAYMANAGER=GNOME|KDE|XDM

Expected results:
DISPLAYMANAGER=GNOME|KDE|WDM|XDM

Additional info:
See /etc/X11/prefdm for the list.
Comment 1 Bill Nottingham 2010-06-29 11:12:26 EDT
It's a deprecated option. At this point, just install wdm (and remove the others) and the right thing happens.
Comment 2 Bill Nottingham 2010-06-29 11:17:31 EDT
Clarified in http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff&h=45532a7c521cd93a98307aa26aaad147c0f6ce87 and the following commit
Comment 3 Kevin Kofler 2010-06-29 11:32:11 EDT
It doesn't make sense to deprecate this option. Users may have more than one DM installed for whatever reason and still want to be able to set the default. Configuring your system by installing or removing packages is not that great an idea.
Comment 4 Bill Nottingham 2010-06-29 11:45:26 EDT
Perhaps 'deprecated' isn't the right word. But it shouldn't need to be set in normal operation.
Comment 5 Jaroslav Reznik 2010-06-29 11:51:17 EDT
(In reply to comment #4)
> Perhaps 'deprecated' isn't the right word. But it shouldn't need to be set in
> normal operation.    

That makes sense. With "deprecated" it looks like the support is completely removed. Could you change it in documentation? Thanks.
Comment 6 Bill Nottingham 2011-02-25 20:03:33 EST
This should be fixed.

Note You need to log in before you can comment on or make changes to this bug.