Bug 609060 - [vdsm] [libvirt intg]Libvirt failed to start after selinux enforcing was changed and libvirt was killed
[vdsm] [libvirt intg]Libvirt failed to start after selinux enforcing was chan...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
high Severity urgent
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 06:38 EDT by Moran Goldboim
Modified: 2010-11-11 09:47 EST (History)
6 users (show)

See Also:
Fixed In Version: libvirt-0_8_1-12_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:47:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace and config files (8.68 KB, application/octet-stream)
2010-06-29 06:38 EDT, Moran Goldboim
no flags Details
Avoid invoking the destroy callback if QEMU monitor open fails (1.34 KB, patch)
2010-06-29 07:05 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Moran Goldboim 2010-06-29 06:38:30 EDT
Created attachment 427638 [details]
gdb backtrace and config files

Description of problem:
libvirt was crashing right after it start - happened after changing the selinux to enforce, killing libvirt and restart the service. backtrace and config files attached, host reboot seems to overcome the problem.

Version-Release number of selected component (if applicable):
happened on libvirt-0.8.1-10.el6.x86_64 which afterwords upgraded to libvirt-0.8.1-11.el6.x86_64

How reproducible:
libvirt failed to start till reboot, wasn't reproducible since 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-29 07:03:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Berrange 2010-06-29 07:05:06 EDT
I think this has the same root cause as this upstream bug. When libvirt fails to connect to the QEMU monitor, it can cause a double-unref of an object

https://www.redhat.com/archives/libvir-list/2010-June/msg00721.html
Comment 4 Daniel Berrange 2010-06-29 07:05:49 EDT
Created attachment 427645 [details]
Avoid invoking the destroy callback if QEMU monitor open fails
Comment 7 Dave Allan 2010-06-29 22:10:59 EDT
libvirt-0_8_1-12_el6 has been built in RHEL-6-candidate with the fix.

Dave
Comment 9 Moran Goldboim 2010-08-31 06:58:31 EDT
verified on libvirt-0_8_1-27
Comment 10 releng-rhel@redhat.com 2010-11-11 09:47:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.