Bug 60909 - gcc 2.96-105 fails to compile Qt C bindings
gcc 2.96-105 fails to compile Qt C bindings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-08 16:41 EST by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 15:38:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bzip2'ed preprocessor output (38.80 KB, application/octet-stream)
2002-03-08 16:42 EST, Bernhard Rosenkraenzer
no flags Details

  None (edit)
Description Bernhard Rosenkraenzer 2002-03-08 16:41:51 EST
c++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I./.. -I/usr/include/kde
-I/usr/lib/qt3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT
-D_REENTRANT -O2 -fno-exceptions -fno-check-new
-Wp,-MD,.deps/qt_QStringList.pp -c qt_QStringList.cpp  -fPIC -DPIC -o
.libs/qt_QStringList.o
qt_QStringList.cpp:25: `QValueListIterator<QString> iterator'
redeclared as different kind of symbol
[qt_QStringList.cpp:25 is static QStringList::Iterator    iterator;]
qt_QStringList.cpp:25: sorry, not implemented: `integer_type' not
supported by dump_expr
qt_QStringList.cpp:25: sorry, not implemented: `pointer_type' not
supported by dump_expr
qt_QStringList.cpp:25: sorry, not implemented: `reference_type' not
supported by dump_expr
/usr/include/g++-3/stl_iterator.h:90: previous declaration of `template
<class _Category, class _Tp, class _Distance = {expression error},
class _Pointer = {expression error}, class _Reference = {expression
error} struct iterator'

Version-Release number of selected component (if applicable):
2.96-105

How Reproducible:
100%

Steps to Reproduce:
1. Try to build kdebindings

Additional Information:
Works with 3.1
Comment 1 Bernhard Rosenkraenzer 2002-03-08 16:42:48 EST
Created attachment 47941 [details]
bzip2'ed preprocessor output
Comment 2 Richard Henderson 2004-10-02 15:38:22 EDT
If it works with 3.1, then fine.  The .ii file present here doesn't
build with 3.2 or later, which just looks like actual c++ conformance
problems with the original.

Note You need to log in before you can comment on or make changes to this bug.